# CVE-2023-46137: twisted.web has disordered HTTP pipeline response

> Attackers can manipulate HTTP pipeline response ordering to read sensitive data from subsequent requests in the Twisted web framework.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-31788, AZL-35140, DEBIAN-CVE-2023-46137, GHSA-xc8x-vp79-p3wm, OESA-2024-1011, OESA-2024-1012, OESA-2024-1013, OESA-2024-1014, OESA-2024-1015, OESA-2024-1047, PYSEC-2023-224, RHSA-2024:1516, RHSA-2024:1518, SUSE-SU-2023:4490-1, SUSE-SU-2023:4607-1, SUSE-SU-2023:4608-1, SUSE-SU-2023:4830-1, UBUNTU-CVE-2023-46137, openSUSE-SU-2024:13430-1

## What is CVE-2023-46137?

CVE-2023-46137 is a medium-severity vulnerability in twisted, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twisted is an event-based framework for internet applications. Prior to version 23.10.0rc1, when sending multiple HTTP requests in one TCP packet, twisted.web will process the requests asynchronously without guaranteeing the response order. If one of the endpoints is controlled by an attacker, the attacker can delay the response on purpose to manipulate the response of the second request when a victim launched two requests using HTTP pipeline. Version 23.10.0rc1 contains a patch for this issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-46137?

3 open source packages ship an affected version, including twisted and Twisted. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 23.10.0rc1 |
| `twisted` | PyPI | All versions | 23.10.0rc1 |
| `Twisted` | PyPI | All versions | 23.10.0rc1 |
| `python-twisted` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-21.el8ost |
| `python-twisted-debugsource` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-21.el8ost |
| `python3-twisted` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-21.el8ost |
| `python3-twisted-debuginfo` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-21.el8ost |
| `python-twisted` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-21.el8ost |
| `python-twisted-debugsource` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-21.el8ost |
| `python3-twisted` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-21.el8ost |
| `python3-twisted-debuginfo` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-21.el8ost |
| `python-Twisted` | SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 17.9.0-150000.3.11.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Python 3 15 SP4 | All versions | 22.10.0-150400.5.13.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Python 3 15 SP5 | All versions | 22.10.0-150400.5.13.1 |
| `python3-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 22.2.0-150400.15.1 |
| `python3-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 22.2.0-150400.15.1 |
| `python-Twisted` | openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.21.1 |
| `python-Twisted` | openSUSE:Leap 15.4 | All versions | 22.10.0-150400.5.13.1 |
| `python3-Twisted` | openSUSE:Leap 15.4 | All versions | 22.2.0-150400.15.1 |
| `python-Twisted` | openSUSE:Leap 15.5 | All versions | 22.10.0-150400.5.13.1 |
| `python3-Twisted` | openSUSE:Leap 15.5 | All versions | 22.2.0-150400.15.1 |
| `python-Twisted` | openSUSE:Tumbleweed | All versions | 22.10.0-9.1 |

Products: Twisted Twisted.

## How do I fix CVE-2023-46137?

Upgrade twisted to 23.10.0rc1 or later.

## Is CVE-2023-46137 being exploited?

There is no known exploitation of CVE-2023-46137 in the wild and no public exploit code.

## Other vulnerabilities in twisted

- [CVE-2026-42304](https://insights.sbomify.com/CVE-2026-42304/): Twisted: Denial of Service (DoS) in twisted.names via Crafted DNS Compression Pointer Chains (high 7.5)
- [CVE-2014-7143](https://insights.sbomify.com/CVE-2014-7143/): Python Twisted trustRoot is not respected in HTTP client (high 7.5)
- [CVE-2019-12855](https://insights.sbomify.com/CVE-2019-12855/): Improper Certificate Validation in Twisted (high 7.4)
- [CVE-2024-41810](https://insights.sbomify.com/CVE-2024-41810/): HTML injection in HTTP redirect body (medium 6.1)
- [CVE-2016-1000111](https://insights.sbomify.com/CVE-2016-1000111/): Forced Browsing in Twisted (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46137 and fix it if it is affected.

What it is: CVE-2023-46137 is a medium-severity vulnerability in twisted, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46137 in the wild and no public exploit code.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 23.10.0rc1
- twisted (PyPI): affected all versions; fixed in 23.10.0rc1
- Twisted (PyPI): affected all versions; fixed in 23.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46137/ (Markdown: https://insights.sbomify.com/CVE-2023-46137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46137
- OSV: https://osv.dev/vulnerability/CVE-2023-46137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46137/
Summaries are generated and may contain mistakes; the official description above is the record.
