# CVE-2023-46138: JumpServer default admin user email leak password reset

> An attacker could register the unregistered default admin email domain to intercept password reset emails and take over the admin account.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Oct 2023
- **Updated:** 5 Sep 2024
- **Also known as:** GHSA-9mrc-75cv-46cq

## What is CVE-2023-46138?

CVE-2023-46138 is a low-severity vulnerability in jumpserver, published on 30 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JumpServer is an open source bastion host and maintenance security audit system that complies with 4A specifications. Prior to version 3.8.0, the default email for initial user admin is `admin[@]mycompany[.]com`, and users reset their passwords by sending an email. Currently, the domain `mycompany.com` has not been registered. However, if it is registered in the future, it may affect the password reset functionality. This issue has been patched in version 3.8.0 by changing the default email domain to `example.com`. Those who cannot upgrade may change the default email domain to `example.com` manually.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2023-46138?

It affects 1 product.


Products: Fit2cloud Jumpserver.

## How do I fix CVE-2023-46138?

No fix has been published for CVE-2023-46138 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-46138 being exploited?

There is no known exploitation of CVE-2023-46138 in the wild and no public exploit code.

## Other vulnerabilities in jumpserver

- [CVE-2024-40628](https://insights.sbomify.com/CVE-2024-40628/): Arbitrary File Read in Ansible Playbooks in Jumpserver (critical 10.0)
- [CVE-2024-40629](https://insights.sbomify.com/CVE-2024-40629/): Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver (critical 10.0)
- [CVE-2024-29201](https://insights.sbomify.com/CVE-2024-29201/): JumpServer's insecure Ansible playbook validation leads to RCE in Celery (critical 10.0)
- [CVE-2024-29202](https://insights.sbomify.com/CVE-2024-29202/): JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery (critical 10.0)
- [CVE-2023-48193](https://insights.sbomify.com/CVE-2023-48193/): Security feature bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46138 and fix it if it is affected.

What it is: CVE-2023-46138 is a low-severity vulnerability in jumpserver, published on 30 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46138 in the wild and no public exploit code.

Affected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46138/ (Markdown: https://insights.sbomify.com/CVE-2023-46138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46138
- OSV: https://osv.dev/vulnerability/CVE-2023-46138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46138/
Summaries are generated and may contain mistakes; the official description above is the record.
