# CVE-2023-46215: Apache Airflow Celery provider Insertion of Sensitive Information into Log File vulnerability

> Attackers with log access can view sensitive credentials in clear text when specific Celery result backends are configured.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2023
- **Updated:** 12 Jun 2025
- **Also known as:** BIT-airflow-2023-46215, GHSA-666g-rfc5-c9jv, PYSEC-2026-1131, PYSEC-2026-2364

## What is CVE-2023-46215?

CVE-2023-46215 is a high-severity vulnerability in Apache Airflow, published on 28 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow.

Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend
Note: the vulnerability is about the information exposed in the logs not about accessing the logs.

This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3.

Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-46215?

7 open source packages ship an affected version, including apache-airflow, airflow and apache-airflow-providers-celery. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 1.10.0 | 2.7.0 |
| `apache-airflow` | PyPI | From 1.10.0 | 2.7.0 |
| `apache-airflow` | PyPI | From 1.10.0 | 2.7.0 |
| `airflow` | Bitnami | From 1.10.0 | 2.7.0 |
| `apache-airflow-providers-celery` | PyPI | From 3.3.0 | 3.4.1 |
| `apache-airflow-providers-celery` | PyPI | From 3.3.0 | 3.4.1 |
| `apache-airflow-providers-celery` | PyPI | From 3.3.0 | 3.4.1 |

Products: Apache Airflow, Apache Airflow Celery Provider.

## How do I fix CVE-2023-46215?

Upgrade apache-airflow to 2.7.0 or later.

## Is CVE-2023-46215 being exploited?

There is no known exploitation of CVE-2023-46215 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46215 and fix it if it is affected.

What it is: CVE-2023-46215 is a high-severity vulnerability in Apache Airflow, published on 28 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46215 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 1.10.0; fixed in 2.7.0
- apache-airflow (PyPI): affected from 1.10.0; fixed in 2.7.0
- apache-airflow (PyPI): affected from 1.10.0; fixed in 2.7.0
- airflow (Bitnami): affected from 1.10.0; fixed in 2.7.0
- apache-airflow-providers-celery (PyPI): affected from 3.3.0; fixed in 3.4.1
- apache-airflow-providers-celery (PyPI): affected from 3.3.0; fixed in 3.4.1
- apache-airflow-providers-celery (PyPI): affected from 3.3.0; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46215/ (Markdown: https://insights.sbomify.com/CVE-2023-46215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46215
- OSV: https://osv.dev/vulnerability/CVE-2023-46215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46215/
Summaries are generated and may contain mistakes; the official description above is the record.
