CVE-2023-46226 Apache IoTDB: Remote Code Execution (RCE) risk via the UDF
Critical 9.8
Published
Updated
Check this codebase for CVE-2023-46226 and fix it if it is affected.
What it is: CVE-2023-46226 is a critical vulnerability in Apache IoTDB, published on 15 Jan 2024.
Exploitation: There is no known exploitation of CVE-2023-46226 in the wild and no public exploit code.
Affected packages and fixed versions:
- apache-iotdb (PyPI): affected from 1.0.0; fixed in 1.3.0
- apache-iotdb (PyPI): affected from 1.0.0; fixed in 1.3.0
- apache-iotdb (PyPI): affected from 1.0.0; fixed in 1.3.0
- org.apache.iotdb:iotdb-core (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.iotdb:iotdb-core (Maven): affected from 1.0.0; fixed in 1.3.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2023-46226/ (Markdown: https://insights.sbomify.com/CVE-2023-46226/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2023-46226?
CVE-2023-46226 is a critical vulnerability in Apache IoTDB, published on 15 Jan 2024.
Official description
Remote Code Execution vulnerability in Apache IoTDB.This issue affects Apache IoTDB: from 1.0.0 through 1.2.2.
Users are recommended to upgrade to version 1.3.0, which fixes the issue.
Weakness: CWE-94
Which versions are affected by CVE-2023-46226?
5 open source packages ship an affected version, including apache-iotdb and org.apache.iotdb:iotdb-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-iotdb PyPI | From 1.0.0 | 1.3.0 |
apache-iotdb PyPI | From 1.0.0 | 1.3.0 |
apache-iotdb PyPI | From 1.0.0 | 1.3.0 |
org.apache.iotdb:iotdb-core Maven | From 1.0.0 | 1.3.0 |
org.apache.iotdb:iotdb-core Maven | From 1.0.0 | 1.3.0 |
Products include Apache Iotdb.
How do I fix CVE-2023-46226?
Upgrade apache-iotdb to 1.3.0 or later.
Is CVE-2023-46226 being exploited?
There is no known exploitation of CVE-2023-46226 in the wild and no public exploit code.
Other vulnerabilities in Apache IoTDB
- CVE-2026-24014 Apache IoTDB: Path Traversal in DataNode Internal RPC Trigger JAR Upload Allows Arbitrary File Write
- CVE-2026-24015 Apache IoTDB: Insecure Default Configuration Vulnerability
- CVE-2026-24713 Apache IoTDB: JEXL Expression Injection Vulnerability
- CVE-2024-24780 Apache IoTDB: Remote Code Execution with untrusted URI of User-defined function
- CVE-2023-51656 Apache IoTDB: Unsafe deserialize map in Sync Tool
Sources
Also known as GHSA-rxgg-273w-rfw7, PYSEC-2024-11.