# CVE-2023-46229: LangChain Server Side Request Forgery vulnerability

> Attackers can exploit Server-Side Request Forgery in LangChain's recursive URL loader to access internal network resources from external servers.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-655w-fm8m-m478, PYSEC-2023-205

## What is CVE-2023-46229?

CVE-2023-46229 is a high-severity server-side request forgery vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LangChain before 0.0.317 allows SSRF via document_loaders/recursive_url_loader.py because crawling can proceed from an external server to an internal server.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-46229?

3 open source packages ship an affected version, including langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.0.317 |
| `langchain` | PyPI | All versions | 0.0.317 |
| `langchain` | PyPI | All versions | 0.0.317 |

Products: Langchain Langchain.

## How do I fix CVE-2023-46229?

Upgrade langchain to 0.0.317 or later.

## Is CVE-2023-46229 being exploited?

There is no known exploitation of CVE-2023-46229 in the wild and no public exploit code.

Public exploit code:

- Python exploit for CVE-2023-46229 with Yasa (github_poc): https://github.com/JarvisDing-sdu/Yasa-CVE-2023-46229

## Other vulnerabilities in n/a

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46229 and fix it if it is affected.

What it is: CVE-2023-46229 is a high-severity server-side request forgery vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46229 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.0.317
- langchain (PyPI): affected all versions; fixed in 0.0.317
- langchain (PyPI): affected all versions; fixed in 0.0.317

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46229/ (Markdown: https://insights.sbomify.com/CVE-2023-46229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46229
- OSV: https://osv.dev/vulnerability/CVE-2023-46229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46229/
Summaries are generated and may contain mistakes; the official description above is the record.
