# CVE-2023-46234: browserify-sign vulnerable via an upper bound check issue in `dsaVerify` that leads to a signature forgery attack

> An upper bound check flaw in browserify-sign allows attackers to forge DSA signatures, bypassing verification checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-31719, CLSA-2026-1782521955, CLSA-2026-1782521956, DEBIAN-CVE-2023-46234, DLA-3635-1, DSA-5539-1, GHSA-x9w5-v3q2-3rhw, ROOT-APP-NPM-CVE-2023-46234, UBUNTU-CVE-2023-46234, USN-6800-1

## What is CVE-2023-46234?

CVE-2023-46234 is a medium-severity vulnerability in Debian Debian Linux, published on 26 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

browserify-sign is a package to duplicate the functionality of node's crypto public key functions, much of this is based on Fedor Indutny's work on indutny/tls.js. An upper bound check issue in `dsaVerify` function allows an attacker to construct signatures that can be successfully verified by any public key, thus leading to a signature forgery attack. All places in this project that involve DSA verification of user-input signatures will be affected by this vulnerability. This issue has been patched in version 4.2.2.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2023-46234?

2 open source packages ship an affected version, including browserify-sign. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `browserify-sign` | npm | From 2.6.0 | 4.2.2 |
| `browserify-sign` | npm | From 2.6.0 | 4.2.2 |

Products: Browserify Browserify-Sign, Debian Debian Linux.

## How do I fix CVE-2023-46234?

Upgrade browserify-sign to 4.2.2 or later.

## Is CVE-2023-46234 being exploited?

There is no known exploitation of CVE-2023-46234 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46234 and fix it if it is affected.

What it is: CVE-2023-46234 is a medium-severity vulnerability in Debian Debian Linux, published on 26 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46234 in the wild and no public exploit code.

Affected packages and fixed versions:
- browserify-sign (npm): affected from 2.6.0; fixed in 4.2.2
- browserify-sign (npm): affected from 2.6.0; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46234/ (Markdown: https://insights.sbomify.com/CVE-2023-46234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46234
- OSV: https://osv.dev/vulnerability/CVE-2023-46234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46234/
Summaries are generated and may contain mistakes; the official description above is the record.
