{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46240 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.4.3 or later.","what":"CVE-2023-46240 is a high-severity vulnerability in CodeIgniter4, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-46240 and fix it if it is affected.\n\nWhat it is: CVE-2023-46240 is a high-severity vulnerability in CodeIgniter4, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-46240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.3\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.3\n- codeigniter (Bitnami): affected all versions; fixed in 4.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46240/ (Markdown: https://insights.sbomify.com/CVE-2023-46240/index.md)","id":"CVE-2023-46240","markdown":"https://insights.sbomify.com/CVE-2023-46240/index.md","name":"CVE-2023-46240","record":{"aliases":["BIT-codeigniter-2023-46240","GHSA-hwxf-qxj7-7rfj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can view confidential information via detailed error reports in production environments of the CodeIgniter4 PHP framework.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"CodeIgniter is a PHP full-stack web framework. Prior to CodeIgniter4 version 4.4.3, if an error or exception occurs, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. Version 4.4.3 contains a patch. As a workaround, replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment","id":"CVE-2023-46240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Potential account take over due to unverified emails from Microsoft Identity Platform","id":"CVE-2023-46241"},"packages":[{"ecosystem":"Bitnami","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2023-46240"},{"ecosystem":"Packagist","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-hwxf-qxj7-7rfj"},{"ecosystem":"Packagist","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-hwxf-qxj7-7rfj"}],"prev":{"headline":"quic-go vulnerable to pointer dereference that can lead to panic","id":"CVE-2023-46239"},"products":["CodeIgniter4"],"published":"2023-10-31","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-05","vendors":["codeigniter4"]},"summary":"Attackers can view confidential information via detailed error reports in production environments of the CodeIgniter4 PHP framework.","url":"https://insights.sbomify.com/CVE-2023-46240/"}