# CVE-2023-46240: CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment

> Attackers can view confidential information via detailed error reports in production environments of the CodeIgniter4 PHP framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2023
- **Updated:** 5 Sep 2024
- **Also known as:** BIT-codeigniter-2023-46240, GHSA-hwxf-qxj7-7rfj

## What is CVE-2023-46240?

CVE-2023-46240 is a high-severity vulnerability in CodeIgniter4, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. Prior to CodeIgniter4 version 4.4.3, if an error or exception occurs, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. Version 4.4.3 contains a patch. As a workaround, replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-46240?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.4.3 |
| `codeigniter4/framework` | Packagist | All versions | 4.4.3 |
| `codeigniter` | Bitnami | All versions | 4.4.3 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2023-46240?

Upgrade codeigniter4/framework to 4.4.3 or later.

## Is CVE-2023-46240 being exploited?

There is no known exploitation of CVE-2023-46240 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46240 and fix it if it is affected.

What it is: CVE-2023-46240 is a high-severity vulnerability in CodeIgniter4, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46240 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.3
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.3
- codeigniter (Bitnami): affected all versions; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46240/ (Markdown: https://insights.sbomify.com/CVE-2023-46240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46240
- OSV: https://osv.dev/vulnerability/CVE-2023-46240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46240/
Summaries are generated and may contain mistakes; the official description above is the record.
