# CVE-2023-46242: Code injection in XWiki Platform

> Attackers with programming privileges can execute arbitrary code via crafted URLs, requiring an upgrade to XWiki Platform.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Nov 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-hgpw-6p4h-j6h5

## What is CVE-2023-46242?

CVE-2023-46242 is a critical code injection vulnerability in Xwiki Xwiki, published on 7 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions it's possible to execute a content with the right of any user via a crafted URL. A user must have `programming` privileges in order to exploit this vulnerability. This issue has been patched in XWiki 14.10.7 and 15.2RC1. Users are advised to upgrade. There are no known workarounds for for this vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-46242?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 14.10.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 14.10.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0 | 15.2-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0 | 15.2-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-46242?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 14.10.7 or 15.2-rc-1.

## Is CVE-2023-46242 being exploited?

There is no known exploitation of CVE-2023-46242 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46242 and fix it if it is affected.

What it is: CVE-2023-46242 is a critical code injection vulnerability in Xwiki Xwiki, published on 7 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46242 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 14.10.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 14.10.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0; fixed in 15.2-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0; fixed in 15.2-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46242/ (Markdown: https://insights.sbomify.com/CVE-2023-46242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46242
- OSV: https://osv.dev/vulnerability/CVE-2023-46242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46242/
Summaries are generated and may contain mistakes; the official description above is the record.
