# CVE-2023-46243: Code execution via the edit action in XWiki platform

> Attackers with edit rights can execute arbitrary Groovy code on the server via crafted URLs, requiring an upgrade to XWiki.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-g2qq-c5j9-5w5w

## What is CVE-2023-46243?

CVE-2023-46243 is a critical code injection vulnerability in Xwiki Xwiki, published on 7 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions it's possible for a user to execute any content with the right of an existing document's content author, provided the user have edit right on it. A crafted URL of the form ` /xwiki/bin/edit//?content=%7B%7Bgroovy%7D%7Dprintln%28%22Hello+from+Groovy%21%22%29%7B%7B%2Fgroovy%7D%7D&xpage=view` can be used to execute arbitrary groovy code on the server. This vulnerability has been patched in XWiki versions 14.10.6 and 15.2RC1. Users are advised to update. There are no known workarounds for this issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-46243?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0 | 15.2-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0 | 15.2-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-46243?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 14.10.6 or 15.2-rc-1.

## Is CVE-2023-46243 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46243 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46243 and fix it if it is affected.

What it is: CVE-2023-46243 is a critical code injection vulnerability in Xwiki Xwiki, published on 7 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46243 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0; fixed in 15.2-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0; fixed in 15.2-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46243/ (Markdown: https://insights.sbomify.com/CVE-2023-46243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46243
- OSV: https://osv.dev/vulnerability/CVE-2023-46243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46243/
Summaries are generated and may contain mistakes; the official description above is the record.
