{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46248 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-46248 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-46248 is a critical code injection vulnerability in sourcegraph cody, published on 31 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-46248 and fix it if it is affected.\n\nWhat it is: CVE-2023-46248 is a critical code injection vulnerability in sourcegraph cody, published on 31 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-46248 in the wild and no public exploit code.\n\nAffected product: sourcegraph cody. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46248/ (Markdown: https://insights.sbomify.com/CVE-2023-46248/index.md)","id":"CVE-2023-46248","markdown":"https://insights.sbomify.com/CVE-2023-46248/index.md","name":"CVE-2023-46248","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"VSCode AI extension","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution by tricking users into opening malicious repositories with overwritten Cody commands.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cody","vendor":"sourcegraph"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-15","name":"External Control of System or Configuration Setting"}],"description":"Cody is an artificial intelligence (AI) coding assistant. The Cody AI VSCode extension versions 0.10.0 through 0.14.0 are vulnerable to Remote Code Execution under certain conditions. An attacker in control of a malicious repository could modify the Cody configuration file `.vscode/cody.json` and overwrite Cody commands. If a user with the extension installed opens this malicious repository and runs a Cody command such as /explain or /doc, this could allow arbitrary code execution on the user's machine. The vulnerability is rated as critical severity, but with low exploitability. It requires the user to have a malicious repository loaded and execute the overwritten command in VS Code. The issue is exploitable regardless of the user blocking code execution on a repository through VS Code Workspace Trust. The issue was found during a regular 3rd party penetration test. The maintainers of Cody do not have evidence of open source repositories having malicious `.vscode/cody.json` files to exploit this vulnerability. The issue is fixed in version 0.14.1 of the Cody VSCode extension. In case users can't promptly upgrade, they should not open any untrusted repositories with the Cody extension loaded.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Overwrite of builtin Cody commands facilitates RCE","id":"CVE-2023-46248","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"authentik potential installation takeover when default admin user is deleted","id":"CVE-2023-46249"},"packages":[],"prev":{"headline":"Vyper has incorrect storage layout for contracts containing large arrays","id":"CVE-2023-46247"},"products":["cody"],"published":"2023-10-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-05","vendors":["sourcegraph"]},"summary":"Attackers can achieve remote code execution by tricking users into opening malicious repositories with overwritten Cody commands.","url":"https://insights.sbomify.com/CVE-2023-46248/"}