# CVE-2023-46249: authentik potential installation takeover when default admin user is deleted

> Attackers can reset the default admin password and take over the system if the initial admin user is deleted, exposing the identity provider to unauthorized control.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Oct 2023
- **Updated:** 5 Sep 2024
- **Also known as:** BIT-authentik-2023-46249, GHSA-rjvp-29xq-f62w

## What is CVE-2023-46249?

CVE-2023-46249 is a critical authentication bypass vulnerability in goauthentik authentik, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

authentik is an open-source Identity Provider. Prior to versions 2023.8.4 and 2023.10.2, when the default admin user has been deleted, it is potentially possible for an attacker to set the password of the default admin user without any authentication. authentik uses a blueprint to create the default admin user, which can also optionally set the default admin users' password from an environment variable. When the user is deleted, the `initial-setup` flow used to configure authentik after the first installation becomes available again. authentik 2023.8.4 and 2023.10.2 fix this issue. As a workaround, ensure the default admin user (Username `akadmin`) exists and has a password set. It is recommended to use a very strong password for this user, and store it in a secure location like a password manager. It is also possible to deactivate the user to prevent any logins as akadmin.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-46249?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2023.8.4, 2023.10.2 |

Products: Goauthentik Authentik.

## How do I fix CVE-2023-46249?

Upgrade authentik to a fixed version for your release line: 2023.8.4 or 2023.10.2.

## Is CVE-2023-46249 being exploited?

There is no known exploitation of CVE-2023-46249 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)
- [CVE-2024-47070](https://insights.sbomify.com/CVE-2024-47070/): authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46249 and fix it if it is affected.

What it is: CVE-2023-46249 is a critical authentication bypass vulnerability in goauthentik authentik, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46249 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2023.8.4, 2023.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46249/ (Markdown: https://insights.sbomify.com/CVE-2023-46249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46249
- OSV: https://osv.dev/vulnerability/CVE-2023-46249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46249/
Summaries are generated and may contain mistakes; the official description above is the record.
