# CVE-2023-46254: Service accounts can see namespaces of other tenants in capsule-proxy

> Tenant owners can list namespaces of other tenants with identical ServiceAccount names, exposing infrastructure metadata.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6758-979h-249x

## What is CVE-2023-46254?

CVE-2023-46254 is a medium-severity vulnerability in projectcapsule capsule-proxy, published on 6 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

capsule-proxy is a reverse proxy for Capsule kubernetes multi-tenancy framework. A bug in the RoleBinding reflector used by `capsule-proxy` gives ServiceAccount tenant owners the right to list Namespaces of other tenants backed by the same owner kind and name. For example consider two tenants `solar` and `wind`. Tenant `solar`, owned by a ServiceAccount named `tenant-owner` in the Namespace `solar`. Tenant `wind`, owned by a ServiceAccount named `tenant-owner` in the Namespace `wind`. The Tenant owner `solar` would be able to list the namespaces of the Tenant `wind` and vice-versa, although this is not correct. The bug introduces an exfiltration vulnerability since allows the listing of Namespace resources of other Tenants, although just in some specific conditions: 1. `capsule-proxy` runs with the `--disable-caching=false` (default value: `false`) and 2. Tenant owners are ServiceAccount, with the same resource name, but in different Namespaces. This vulnerability doesn't allow any privilege escalation on the outer tenant Namespace-scoped resources, since the Kubernetes RBAC is enforcing this. This issue has been addressed in version 0.4.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-46254?

4 open source packages ship an affected version, including github.com/projectcapsule/capsule-proxy and github.com/projectcapsule/capsule. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/projectcapsule/capsule-proxy` | Go | All versions | 0.4.5 |
| `github.com/projectcapsule/capsule-proxy` | Go | All versions | 0.4.5 |
| `github.com/projectcapsule/capsule` | Go | All versions | 0.4.5 |
| `github.com/projectcapsule/capsule` | Go | All versions | 0.4.5 |

Products: Clastix Capsule, Clastix Capsule-Proxy.

## How do I fix CVE-2023-46254?

Upgrade github.com/projectcapsule/capsule-proxy to 0.4.5 or later.

## Is CVE-2023-46254 being exploited?

There is no known exploitation of CVE-2023-46254 in the wild and no public exploit code.

## Other vulnerabilities in projectcapsule capsule-proxy

- [CVE-2022-46167](https://insights.sbomify.com/CVE-2022-46167/): Capsule vulnerable to privilege escalation by ServiceAccount deployed in a Tenant Namespace (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46254 and fix it if it is affected.

What it is: CVE-2023-46254 is a medium-severity vulnerability in projectcapsule capsule-proxy, published on 6 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46254 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/projectcapsule/capsule-proxy (Go): affected all versions; fixed in 0.4.5
- github.com/projectcapsule/capsule-proxy (Go): affected all versions; fixed in 0.4.5
- github.com/projectcapsule/capsule (Go): affected all versions; fixed in 0.4.5
- github.com/projectcapsule/capsule (Go): affected all versions; fixed in 0.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46254/ (Markdown: https://insights.sbomify.com/CVE-2023-46254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46254
- OSV: https://osv.dev/vulnerability/CVE-2023-46254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46254/
Summaries are generated and may contain mistakes; the official description above is the record.
