CVE-2023-46302 Apache Submarine: Fix CVE-2022-1471 SnakeYaml unsafe deserialization

Critical 9.8 Published Updated

Attackers can execute arbitrary code via unsafe YAML deserialization in Apache Submarine server endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-46302?

CVE-2023-46302 is a critical unsafe deserialization vulnerability in Apache Submarine, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Software Foundation Apache Submarine has a bug when serializing against yaml. The bug is caused by snakeyaml https://nvd.nist.gov/vuln/detail/CVE-2022-1471 .

Apache Submarine uses JAXRS to define REST endpoints. In order to handle YAML requests (using application/yaml content-type), it defines a YamlEntityProvider entity provider that will process all incoming YAML requests. In order to unmarshal the request, the readFrom method is invoked, passing the entityStream containing the user-supplied data in `submarine-server/server-core/src/main/java/org/apache/submarine/server/utils/YamlUtils.java`. We have now fixed this issue in the new version by replacing to `jackson-dataformat-yaml`. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. Users are recommended to upgrade to version 0.8.0, which fixes this issue. If using the version smaller than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1054 and rebuild the submart-server image to fix this.

Weakness: CWE-502

Which versions are affected by CVE-2023-46302?

3 open source packages ship an affected version, including apache-submarine. It affects 1 product.

PackageAffectedFixed in
apache-submarine PyPIFrom 0.7.00.8.0
apache-submarine PyPIFrom 0.7.00.8.0
apache-submarine PyPIFrom 0.7.00.8.0

Products include Apache Submarine.

How do I fix CVE-2023-46302?

Upgrade apache-submarine to 0.8.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2023-46302 being exploited?

There is no known exploitation of CVE-2023-46302 in the wild and no public exploit code.

Sources

Also known as GHSA-8hcr-5x2g-9f7j, PYSEC-2023-240.

Is CVE-2023-46302 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free