# CVE-2023-46302: Apache Submarine: Fix CVE-2022-1471 SnakeYaml unsafe deserialization

> Attackers can execute arbitrary code via unsafe YAML deserialization in Apache Submarine server endpoints.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8hcr-5x2g-9f7j, PYSEC-2023-240

## What is CVE-2023-46302?

CVE-2023-46302 is a critical unsafe deserialization vulnerability in Apache Submarine, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Software Foundation Apache Submarine has a bug when serializing against yaml. The bug is caused by snakeyaml  https://nvd.nist.gov/vuln/detail/CVE-2022-1471 .

Apache Submarine uses JAXRS to define REST endpoints.  In order to
handle YAML requests (using application/yaml content-type), it defines
a YamlEntityProvider entity provider that will process all incoming
YAML requests.  In order to unmarshal the request, the readFrom method
is invoked, passing the entityStream containing the user-supplied data in `submarine-server/server-core/src/main/java/org/apache/submarine/server/utils/YamlUtils.java`.
 
We have now fixed this issue in the new version by replacing to `jackson-dataformat-yaml`.
This issue affects Apache Submarine: from 0.7.0 before 0.8.0. Users are recommended to upgrade to version 0.8.0, which fixes this issue.
If using the version smaller than 0.8.0  and not want to upgrade, you can try cherry-pick PR  https://github.com/apache/submarine/pull/1054  and rebuild the submart-server image to fix this.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-46302?

3 open source packages ship an affected version, including apache-submarine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-submarine` | PyPI | From 0.7.0 | 0.8.0 |
| `apache-submarine` | PyPI | From 0.7.0 | 0.8.0 |
| `apache-submarine` | PyPI | From 0.7.0 | 0.8.0 |

Products: Apache Submarine.

## How do I fix CVE-2023-46302?

Upgrade apache-submarine to 0.8.0 or later.

## Is CVE-2023-46302 being exploited?

There is no known exploitation of CVE-2023-46302 in the wild and no public exploit code.

## Other vulnerabilities in Apache Submarine

- [CVE-2024-36264](https://insights.sbomify.com/CVE-2024-36264/): Apache Submarine Commons Utils: default secret (critical 9.8)
- [CVE-2024-36265](https://insights.sbomify.com/CVE-2024-36265/): Apache Submarine Server Core: authorization bypass (critical 9.8)
- [CVE-2023-37924](https://insights.sbomify.com/CVE-2023-37924/): Apache Submarine: SQL injection from unauthorized login (critical 9.8)
- [CVE-2024-36263](https://insights.sbomify.com/CVE-2024-36263/): Apache Submarine Server Core: SQL injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46302 and fix it if it is affected.

What it is: CVE-2023-46302 is a critical unsafe deserialization vulnerability in Apache Submarine, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46302 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-submarine (PyPI): affected from 0.7.0; fixed in 0.8.0
- apache-submarine (PyPI): affected from 0.7.0; fixed in 0.8.0
- apache-submarine (PyPI): affected from 0.7.0; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46302/ (Markdown: https://insights.sbomify.com/CVE-2023-46302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46302
- OSV: https://osv.dev/vulnerability/CVE-2023-46302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46302/
Summaries are generated and may contain mistakes; the official description above is the record.
