CVE-2023-46306 Command injection in n/a
Authenticated attackers can execute arbitrary OS commands with elevated privileges via unsanitized input in the web administration interface.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-46306?
CVE-2023-46306 is a high-severity command injection vulnerability in n/a, published on 22 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The web administration interface in NetModule Router Software (NRSW) 4.6 before 4.6.0.106 and 4.8 before 4.8.0.101 executes an OS command constructed with unsanitized user input: shell metacharacters in the /admin/gnssAutoAlign.php device_id parameter. This occurs because another thread can be started before the trap that triggers the cleanup function. A successful exploit could allow an authenticated user to execute arbitrary commands with elevated privileges. NOTE: this is different from CVE-2023-0861 and CVE-2023-0862, which were fixed in version 4.6.0.105.
Weakness: CWE-78
Which versions are affected by CVE-2023-46306?
It affects 1 product.
Products include Netmodule Netmodule Router Software.
How do I fix CVE-2023-46306?
No fix has been published for CVE-2023-46306 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2023-46306 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46306 exists.
Other vulnerabilities in n/a
Sources
Also known as GHSA-4qww-v3r6-7335.