{"answers":{"affected":"5 open source packages ship an affected version, including plotly/plotly.js, plotly and plotly.js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46308 in the wild and no public exploit code.","fix":"Upgrade plotly/plotly.js to 2.25.2 or later.","what":"CVE-2023-46308 is a critical vulnerability in n/a, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-46308 and fix it if it is affected.\n\nWhat it is: CVE-2023-46308 is a critical vulnerability in n/a, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-46308 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plotly/plotly.js (Packagist): affected all versions; fixed in 2.25.2\n- plotly/plotly.js (Packagist): affected all versions; fixed in 2.25.2\n- plotly (CRAN): affected from 2.0.2; fixed in 4.12.0\n- plotly.js (npm): affected all versions; fixed in 2.25.2\n- plotly.js (npm): affected all versions; fixed in 2.25.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46308/ (Markdown: https://insights.sbomify.com/CVE-2023-46308/index.md)","id":"CVE-2023-46308","markdown":"https://insights.sbomify.com/CVE-2023-46308/index.md","name":"CVE-2023-46308","record":{"aliases":["GHSA-wjc4-73q6-gv3m","RSEC-2025-1","openSUSE-SU-2024:13607-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript plotting library","requires_auth":"none","summary":"Prototype pollution in plotly.js allows attackers to manipulate object prototypes, potentially leading to code execution or security bypasses.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"plotly.js","vendor":"plotly"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.","ecosystems":["CRAN","Packagist","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"plotly.js prototype pollution vulnerability","id":"CVE-2023-46308","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2023"},"n_packages":5,"n_references":3,"next":{"headline":"WordPress wpDiscuz plugin \u003c= 7.6.10 - Broken Access Control vulnerability","id":"CVE-2023-46309"},"packages":[{"ecosystem":"CRAN","fixed":["4.12.0"],"introduced":["2.0.2"],"last_affected":[],"package":"plotly","purl":"pkg:cran/plotly","source":"RSEC-2025-1"},{"ecosystem":"Packagist","fixed":["2.25.2"],"introduced":["0"],"last_affected":[],"package":"plotly/plotly.js","purl":null,"source":"GHSA-wjc4-73q6-gv3m"},{"ecosystem":"Packagist","fixed":["2.25.2"],"introduced":["0"],"last_affected":[],"package":"plotly/plotly.js","purl":"pkg:composer/plotly/plotly.js","source":"GHSA-wjc4-73q6-gv3m"},{"ecosystem":"npm","fixed":["2.25.2"],"introduced":["0"],"last_affected":[],"package":"plotly.js","purl":null,"source":"GHSA-wjc4-73q6-gv3m"},{"ecosystem":"npm","fixed":["2.25.2"],"introduced":["0"],"last_affected":[],"package":"plotly.js","purl":"pkg:npm/plotly.js","source":"GHSA-wjc4-73q6-gv3m"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2023-46307"},"products":["n/a"],"published":"2024-01-03","related":[{"cvss_score":6.1,"headline":"Cross Site Scripting (XSS) in plotly.js","id":"CVE-2017-1000006","kev_date_added":null,"published":"2017-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"Apache-2.0","name":"R Consortium","prefix":"RSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-24","vendors":["n/a"]},"summary":"Prototype pollution in plotly.js allows attackers to manipulate object prototypes, potentially leading to code execution or security bypasses.","url":"https://insights.sbomify.com/CVE-2023-46308/"}