# CVE-2023-46308: plotly.js prototype pollution vulnerability

> Prototype pollution in plotly.js allows attackers to manipulate object prototypes, potentially leading to code execution or security bypasses.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2024
- **Updated:** 24 Dec 2025
- **Also known as:** GHSA-wjc4-73q6-gv3m, RSEC-2025-1, openSUSE-SU-2024:13607-1

## What is CVE-2023-46308?

CVE-2023-46308 is a critical vulnerability in n/a, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-46308?

5 open source packages ship an affected version, including plotly/plotly.js, plotly and plotly.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plotly/plotly.js` | Packagist | All versions | 2.25.2 |
| `plotly/plotly.js` | Packagist | All versions | 2.25.2 |
| `plotly` | CRAN | From 2.0.2 | 4.12.0 |
| `plotly.js` | npm | All versions | 2.25.2 |
| `plotly.js` | npm | All versions | 2.25.2 |

Products: Plotly Plotly.js.

## How do I fix CVE-2023-46308?

Upgrade plotly/plotly.js to 2.25.2 or later.

## Is CVE-2023-46308 being exploited?

There is no known exploitation of CVE-2023-46308 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-1000006](https://insights.sbomify.com/CVE-2017-1000006/): Cross Site Scripting (XSS) in plotly.js (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46308 and fix it if it is affected.

What it is: CVE-2023-46308 is a critical vulnerability in n/a, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46308 in the wild and no public exploit code.

Affected packages and fixed versions:
- plotly/plotly.js (Packagist): affected all versions; fixed in 2.25.2
- plotly/plotly.js (Packagist): affected all versions; fixed in 2.25.2
- plotly (CRAN): affected from 2.0.2; fixed in 4.12.0
- plotly.js (npm): affected all versions; fixed in 2.25.2
- plotly.js (npm): affected all versions; fixed in 2.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46308/ (Markdown: https://insights.sbomify.com/CVE-2023-46308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46308
- OSV: https://osv.dev/vulnerability/CVE-2023-46308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46308/
Summaries are generated and may contain mistakes; the official description above is the record.
