# CVE-2023-46445: AsyncSSH Rogue Extension Negotiation

> Attackers can bypass SSH extension negotiation security checks via man-in-the-middle attacks in AsyncSSH, requiring library upgrades.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2023
- **Updated:** 25 Feb 2026
- **Also known as:** DEBIAN-CVE-2023-46445, GHSA-cfc2-wr2v-gxm5, PYSEC-2023-237, UBUNTU-CVE-2023-46445, openSUSE-SU-2024:13417-1

## What is CVE-2023-46445?

CVE-2023-46445 is a medium-severity vulnerability in n/a, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in AsyncSSH before 2.14.1 allows attackers to control the extension info message (RFC 8308) via a man-in-the-middle attack, aka a "Rogue Extension Negotiation."

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-46445?

3 open source packages ship an affected version, including asyncssh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asyncssh` | PyPI | All versions | 2.14.1 |
| `asyncssh` | PyPI | All versions | 2.14.1 |
| `asyncssh` | PyPI | All versions | 2.14.1 |

Products: Asyncssh Project Asyncssh.

## How do I fix CVE-2023-46445?

Upgrade asyncssh to 2.14.1 or later.

## Is CVE-2023-46445 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46445 exists.

## Other vulnerabilities in n/a

- [CVE-2018-7749](https://insights.sbomify.com/CVE-2018-7749/): AsyncSSH SSH Server Authentication Bypass (critical 9.8)
- [CVE-2026-45309](https://insights.sbomify.com/CVE-2026-45309/): AsyncSSH `AuthorizedKeysFile %u` path traversal allows attacker-selected authorized keys to authenticate a traversal username (high 8.2)
- [CVE-2023-46446](https://insights.sbomify.com/CVE-2023-46446/): AsyncSSH Rogue Session Attack (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46445 and fix it if it is affected.

What it is: CVE-2023-46445 is a medium-severity vulnerability in n/a, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46445 exists.

Affected packages and fixed versions:
- asyncssh (PyPI): affected all versions; fixed in 2.14.1
- asyncssh (PyPI): affected all versions; fixed in 2.14.1
- asyncssh (PyPI): affected all versions; fixed in 2.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46445/ (Markdown: https://insights.sbomify.com/CVE-2023-46445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46445
- OSV: https://osv.dev/vulnerability/CVE-2023-46445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46445/
Summaries are generated and may contain mistakes; the official description above is the record.
