CVE-2023-4647 Allocation of Resources Without Limits or Throttling in GitLab

Medium 5.3 Published Updated

Attackers can bypass API pagination limits to cause denial of service on GitLab instances by exhausting resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-4647?

CVE-2023-4647 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 15.2 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1 in which the projects API pagination can be skipped, potentially leading to DoS on certain instances.

Weakness: CWE-770

Which versions are affected by CVE-2023-4647?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.2.016.1.5, 16.2.5, 16.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-4647?

Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-4647 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4647 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-4647, GHSA-43fr-qgqj-789v, UBUNTU-CVE-2023-4647.

Is CVE-2023-4647 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free