# CVE-2023-46502: OpenCRX allows a remote attacker to execute arbitrary code via a crafted request

> Remote attackers can read internal files and perform SSRF via insecure XML parsing in openCRX, requiring an upgrade to secure versions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2023
- **Updated:** 9 Sep 2024
- **Also known as:** GHSA-q74f-rf27-8hxc

## What is CVE-2023-46502?

CVE-2023-46502 is a critical vulnerability in n/a, published on 30 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in openCRX v.5.2.2 allows a remote attacker to read internal files and execute server side request forgery attack via insecure DocumentBuilderFactory.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference), CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-46502?

2 open source packages ship an affected version, including org.opencrx:opencrx-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencrx:opencrx-client` | Maven | All versions | 5.3.0 |
| `org.opencrx:opencrx-client` | Maven | All versions | 5.3.0 |

Products: Opencrx Opencrx.

## How do I fix CVE-2023-46502?

Upgrade org.opencrx:opencrx-client to 5.3.0 or later.

## Is CVE-2023-46502 being exploited?

There is no known exploitation of CVE-2023-46502 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-7378](https://insights.sbomify.com/CVE-2020-7378/): CRIXP OpenCRX Unverified Password Change (critical 9.1)
- [CVE-2023-27151](https://insights.sbomify.com/CVE-2023-27151/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-40809](https://insights.sbomify.com/CVE-2023-40809/): Cross-site Scripting in OpenCRX (medium 6.1)
- [CVE-2023-40810](https://insights.sbomify.com/CVE-2023-40810/): Cross-site Scripting in OpenCRX (medium 6.1)
- [CVE-2023-40812](https://insights.sbomify.com/CVE-2023-40812/): Cross-site Scripting in OpenCRX (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46502 and fix it if it is affected.

What it is: CVE-2023-46502 is a critical vulnerability in n/a, published on 30 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46502 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencrx:opencrx-client (Maven): affected all versions; fixed in 5.3.0
- org.opencrx:opencrx-client (Maven): affected all versions; fixed in 5.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46502/ (Markdown: https://insights.sbomify.com/CVE-2023-46502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46502
- OSV: https://osv.dev/vulnerability/CVE-2023-46502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46502/
Summaries are generated and may contain mistakes; the official description above is the record.
