# CVE-2023-46565: Buffer Overflow vulnerability in osrg gobgp

> A remote attacker can cause a denial of service in GoBGP via a buffer overflow in the handlingError function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2024
- **Updated:** 6 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-46565, GHSA-6rqv-5cg7-m4x3, GO-2024-3124, UBUNTU-CVE-2023-46565, openSUSE-SU-2024:14564-1

## What is CVE-2023-46565?

CVE-2023-46565 is a high-severity memory corruption vulnerability in n/a, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Buffer Overflow vulnerability in osrg gobgp commit 419c50dfac578daa4d11256904d0dc182f1a9b22 allows a remote attacker to cause a denial of service via the handlingError function in pkg/server/fsm.go.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2023-46565?

3 open source packages ship an affected version, including github.com/osrg/gobgp/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v3` | Go | All versions to 3.20.0 | None |
| `github.com/osrg/gobgp/v3` | Go | All versions to 3.20.0 | None |
| `github.com/osrg/gobgp/v3` | Go | All versions | 3.20.0 |
| `lxd` | openSUSE:Tumbleweed | All versions | 5.21.1-2.1 |

## How do I fix CVE-2023-46565?

Upgrade github.com/osrg/gobgp/v3 to 3.20.0 or later.

## Is CVE-2023-46565 being exploited?

There is no known exploitation of CVE-2023-46565 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46565 and fix it if it is affected.

What it is: CVE-2023-46565 is a high-severity memory corruption vulnerability in n/a, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46565 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v3 (Go): affected all versions up to 3.20.0; no fix listed
- github.com/osrg/gobgp/v3 (Go): affected all versions up to 3.20.0; no fix listed
- github.com/osrg/gobgp/v3 (Go): affected all versions; fixed in 3.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46565/ (Markdown: https://insights.sbomify.com/CVE-2023-46565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46565
- OSV: https://osv.dev/vulnerability/CVE-2023-46565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46565/
Summaries are generated and may contain mistakes; the official description above is the record.
