CVE-2023-4658 Incorrect Authorization in GitLab

Low 3.1 Published Updated

Guest users can bypass merge restrictions to modify code when granted permissions via group settings, requiring GitLab Enterprise Edition upgrades.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-4658?

CVE-2023-4658 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 8.13 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for an attacker to abuse the `Allowed to merge` permission as a guest user, when granted the permission through a group.

Weakness: CWE-863

Which versions are affected by CVE-2023-4658?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.13.016.4.3, 16.5.3, 16.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-4658?

Upgrade gitlab to a fixed version for your release line: 16.4.3, 16.5.3 or 16.6.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-4658 being exploited?

There is no known exploitation of CVE-2023-4658 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-4658, GHSA-5p8h-m559-wpw7.

Is CVE-2023-4658 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free