CVE-2023-46651 Jenkins Warnings Plugin exposures system-scoped credentials
Attackers with Item/Configure permission can access and capture unauthorized credentials due to improper context handling in the Jenkins Warnings Plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-46651?
CVE-2023-46651 is a medium-severity vulnerability in Jenkins Warnings Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to. This fix has been backported to 10.4.1.
Weakness: CWE-522
Which versions are affected by CVE-2023-46651?
4 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.jenkins.plugins:warnings-ng Maven | All versions | 10.4.1 |
io.jenkins.plugins:warnings-ng Maven | All versions | 10.4.1 |
io.jenkins.plugins:warnings-ng Maven | From 10.5.0 | 10.5.1 |
io.jenkins.plugins:warnings-ng Maven | From 10.5.0 | 10.5.1 |
Products include Jenkins Warnings.
How do I fix CVE-2023-46651?
Upgrade io.jenkins.plugins:warnings-ng to a fixed version for your release line: 10.4.1 or 10.5.1.
Is CVE-2023-46651 being exploited?
There is no known exploitation of CVE-2023-46651 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Warnings Plugin
Sources
Also known as GHSA-66hv-fhcm-7xm7.