{"answers":{"affected":"4 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46651 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:warnings-ng to a fixed version for your release line: 10.4.1 or 10.5.1.","what":"CVE-2023-46651 is a medium-severity vulnerability in Jenkins Warnings Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-46651 and fix it if it is affected.\n\nWhat it is: CVE-2023-46651 is a medium-severity vulnerability in Jenkins Warnings Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-46651 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 10.4.1\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 10.4.1\n- io.jenkins.plugins:warnings-ng (Maven): affected from 10.5.0; fixed in 10.5.1\n- io.jenkins.plugins:warnings-ng (Maven): affected from 10.5.0; fixed in 10.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46651/ (Markdown: https://insights.sbomify.com/CVE-2023-46651/index.md)","id":"CVE-2023-46651","markdown":"https://insights.sbomify.com/CVE-2023-46651/index.md","name":"CVE-2023-46651","record":{"aliases":["GHSA-66hv-fhcm-7xm7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Warnings Plugin","requires_auth":"low_privilege","summary":"Attackers with Item/Configure permission can access and capture unauthorized credentials due to improper context handling in the Jenkins Warnings Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"warnings","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to. This fix has been backported to 10.4.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Warnings Plugin exposures system-scoped credentials","id":"CVE-2023-46651","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"Jenkins lambdatest-automation Plugin missing permission check","id":"CVE-2023-46652"},"packages":[{"ecosystem":"Maven","fixed":["10.4.1"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-66hv-fhcm-7xm7"},{"ecosystem":"Maven","fixed":["10.4.1"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-66hv-fhcm-7xm7"},{"ecosystem":"Maven","fixed":["10.5.1"],"introduced":["10.5.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-66hv-fhcm-7xm7"},{"ecosystem":"Maven","fixed":["10.5.1"],"introduced":["10.5.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-66hv-fhcm-7xm7"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins GitHub Plugin","id":"CVE-2023-46650"},"products":["Jenkins Warnings Plugin"],"published":"2023-10-25","related":[{"cvss_score":8.8,"headline":"CSRF vulnerability in Jenkins warnings Plugin allows remote code execution","id":"CVE-2020-2280","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":8.8,"headline":"Sandbox Bypass via CSRF in Jenkins Warnings Plugin","id":"CVE-2019-1003007","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":8.8,"headline":"XXE vulnerability Jenkins Warnings Plugin","id":"CVE-2018-1000012","kev_date_added":null,"published":"2018-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Jenkins Project"]},"summary":"Attackers with Item/Configure permission can access and capture unauthorized credentials due to improper context handling in the Jenkins Warnings Plugin.","url":"https://insights.sbomify.com/CVE-2023-46651/"}