# CVE-2023-46651: Jenkins Warnings Plugin exposures system-scoped credentials

> Attackers with Item/Configure permission can access and capture unauthorized credentials due to improper context handling in the Jenkins Warnings Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-66hv-fhcm-7xm7

## What is CVE-2023-46651?

CVE-2023-46651 is a medium-severity vulnerability in Jenkins Warnings Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to. This fix has been backported to 10.4.1.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-46651?

4 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 10.4.1 |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 10.4.1 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 10.5.0 | 10.5.1 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 10.5.0 | 10.5.1 |

Products: Jenkins Warnings.

## How do I fix CVE-2023-46651?

Upgrade io.jenkins.plugins:warnings-ng to a fixed version for your release line: 10.4.1 or 10.5.1.

## Is CVE-2023-46651 being exploited?

There is no known exploitation of CVE-2023-46651 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Warnings Plugin

- [CVE-2020-2280](https://insights.sbomify.com/CVE-2020-2280/): CSRF vulnerability in Jenkins warnings Plugin allows remote code execution (high 8.8)
- [CVE-2019-1003007](https://insights.sbomify.com/CVE-2019-1003007/): Sandbox Bypass via CSRF in Jenkins Warnings Plugin (high 8.8)
- [CVE-2018-1000012](https://insights.sbomify.com/CVE-2018-1000012/): XXE vulnerability Jenkins Warnings Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46651 and fix it if it is affected.

What it is: CVE-2023-46651 is a medium-severity vulnerability in Jenkins Warnings Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46651 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 10.4.1
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 10.4.1
- io.jenkins.plugins:warnings-ng (Maven): affected from 10.5.0; fixed in 10.5.1
- io.jenkins.plugins:warnings-ng (Maven): affected from 10.5.0; fixed in 10.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46651/ (Markdown: https://insights.sbomify.com/CVE-2023-46651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46651
- OSV: https://osv.dev/vulnerability/CVE-2023-46651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46651/
Summaries are generated and may contain mistakes; the official description above is the record.
