# CVE-2023-46652: Jenkins lambdatest-automation Plugin missing permission check

> Attackers with read permissions can enumerate LambdaTest credential IDs due to missing permission checks in the Jenkins plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-vw64-g7c6-mm7g

## What is CVE-2023-46652?

CVE-2023-46652 is a medium-severity missing authorization vulnerability in Jenkins lambdatest-automation Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins lambdatest-automation Plugin 1.20.9 and earlier allows attackers with Overall/Read permission to enumerate credentials IDs of LAMBDATEST credentials stored in Jenkins.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-46652?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:lambdatest-automation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:lambdatest-automation` | Maven | All versions | 1.20.10 |
| `org.jenkins-ci.plugins:lambdatest-automation` | Maven | All versions | 1.20.10 |

Products: Jenkins Lambdatest-Automation.

## How do I fix CVE-2023-46652?

Upgrade org.jenkins-ci.plugins:lambdatest-automation to 1.20.10 or later.

## Is CVE-2023-46652 being exploited?

There is no known exploitation of CVE-2023-46652 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins lambdatest-automation Plugin

- [CVE-2023-46653](https://insights.sbomify.com/CVE-2023-46653/): Jenkins lambdatest-automation Plugin may expose Credentials access token (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46652 and fix it if it is affected.

What it is: CVE-2023-46652 is a medium-severity missing authorization vulnerability in Jenkins lambdatest-automation Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46652 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:lambdatest-automation (Maven): affected all versions; fixed in 1.20.10
- org.jenkins-ci.plugins:lambdatest-automation (Maven): affected all versions; fixed in 1.20.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46652/ (Markdown: https://insights.sbomify.com/CVE-2023-46652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46652
- OSV: https://osv.dev/vulnerability/CVE-2023-46652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46652/
Summaries are generated and may contain mistakes; the official description above is the record.
