# CVE-2023-46653: Jenkins lambdatest-automation Plugin may expose Credentials access token

> Attackers can obtain LambdaTest access tokens from Jenkins logs, compromising cloud testing credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-hpv3-f5p7-pxj9

## What is CVE-2023-46653?

CVE-2023-46653 is a medium-severity vulnerability in Jenkins lambdatest-automation Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins lambdatest-automation Plugin 1.20.10 and earlier logs LAMBDATEST Credentials access token at the INFO level, potentially resulting in its exposure.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2023-46653?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:lambdatest-automation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:lambdatest-automation` | Maven | All versions | 1.21.0 |
| `org.jenkins-ci.plugins:lambdatest-automation` | Maven | All versions | 1.21.0 |

Products: Jenkins Lambdatest-Automation.

## How do I fix CVE-2023-46653?

Upgrade org.jenkins-ci.plugins:lambdatest-automation to 1.21.0 or later.

## Is CVE-2023-46653 being exploited?

There is no known exploitation of CVE-2023-46653 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins lambdatest-automation Plugin

- [CVE-2023-46652](https://insights.sbomify.com/CVE-2023-46652/): Jenkins lambdatest-automation Plugin missing permission check (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46653 and fix it if it is affected.

What it is: CVE-2023-46653 is a medium-severity vulnerability in Jenkins lambdatest-automation Plugin, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46653 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:lambdatest-automation (Maven): affected all versions; fixed in 1.21.0
- org.jenkins-ci.plugins:lambdatest-automation (Maven): affected all versions; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46653/ (Markdown: https://insights.sbomify.com/CVE-2023-46653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46653
- OSV: https://osv.dev/vulnerability/CVE-2023-46653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46653/
Summaries are generated and may contain mistakes; the official description above is the record.
