# CVE-2023-46695: Django potential denial of service vulnerability in UsernameField on Windows

> Attackers can cause denial of service in Django applications on Windows by submitting inputs with many Unicode characters, triggering slow NFKC normalization.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-django-2023-46695, GHSA-qmf9-6jqf-j8fq, OESA-2023-1846, PYSEC-2023-222

## What is CVE-2023-46695?

CVE-2023-46695 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 3.2 before 3.2.23, 4.1 before 4.1.13, and 4.2 before 4.2.7. The NFKC normalization is slow on Windows. As a consequence, django.contrib.auth.forms.UsernameField is subject to a potential DoS (denial of service) attack via certain inputs with a very large number of Unicode characters.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-46695?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.23, 4.1.13, 4.2.7 |
| `django` | PyPI | From 3.2 | 3.2.23, 4.1.13, 4.2.7 |
| `django` | PyPI | From 3.2a1 | 3.2.23 |
| `django` | PyPI | From 4.1a1 | 4.1.13 |
| `django` | PyPI | From 4.2a1 | 4.2.7 |
| `Django` | PyPI | From 3.2a1 | 3.2.23 |
| `Django` | PyPI | From 4.1a1 | 4.1.13 |
| `Django` | PyPI | From 4.2a1 | 4.2.7 |

Products: Djangoproject Django.

## How do I fix CVE-2023-46695?

Upgrade django to a fixed version for your release line: 3.2.23, 4.1.13 or 4.2.7.

## Is CVE-2023-46695 being exploited?

There is no known exploitation of CVE-2023-46695 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46695 and fix it if it is affected.

What it is: CVE-2023-46695 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46695 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.23, 4.1.13, 4.2.7
- django (PyPI): affected from 3.2; fixed in 3.2.23, 4.1.13, 4.2.7
- django (PyPI): affected from 3.2a1; fixed in 3.2.23
- django (PyPI): affected from 4.1a1; fixed in 4.1.13
- django (PyPI): affected from 4.2a1; fixed in 4.2.7
- Django (PyPI): affected from 3.2a1; fixed in 3.2.23
- Django (PyPI): affected from 4.1a1; fixed in 4.1.13
- Django (PyPI): affected from 4.2a1; fixed in 4.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46695/ (Markdown: https://insights.sbomify.com/CVE-2023-46695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46695
- OSV: https://osv.dev/vulnerability/CVE-2023-46695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46695/
Summaries are generated and may contain mistakes; the official description above is the record.
