# CVE-2023-46722: Pimcore Admin Classic Bundle Cross-site Scripting (XSS) in PDF previews

> Attackers can execute scripts in PDF previews to steal cookies and hijack user accounts in the Pimcore Admin Classic Bundle.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Oct 2023
- **Updated:** 5 Sep 2024
- **Also known as:** GHSA-jfxw-6c5v-c42f

## What is CVE-2023-46722?

CVE-2023-46722 is a medium-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Pimcore Admin Classic Bundle provides a backend UI for Pimcore. Prior to version 1.2.0, a cross-site scripting vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites. Users should upgrade to version 1.2.0 to receive a patch or, as a workaround, apply the patch manually.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-46722?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.0 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.0 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2023-46722?

Upgrade pimcore/admin-ui-classic-bundle to 1.2.0 or later.

## Is CVE-2023-46722 being exploited?

There is no known exploitation of CVE-2023-46722 in the wild and no public exploit code.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46722 and fix it if it is affected.

What it is: CVE-2023-46722 is a medium-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46722 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.0
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46722/ (Markdown: https://insights.sbomify.com/CVE-2023-46722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46722
- OSV: https://osv.dev/vulnerability/CVE-2023-46722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46722/
Summaries are generated and may contain mistakes; the official description above is the record.
