# CVE-2023-46724: SQUID-2023:4 Denial of Service in SSL Certificate validation

> Remote attackers can cause a denial of service in Squid proxy via crafted SSL certificates during TLS handshakes when SSL-Bump or HTTPS is enabled.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2023-46724, AZL-31838, CLSA-2023-1700592773, CLSA-2023-1700592975, CLSA-2023-1701285122, CLSA-2023-1701286147, CLSA-2024-1735126310, DEBIAN-CVE-2023-46724, GHSA-73m6-jm96-c6r3, ROOT-OS-ALPINE-318-CVE-2023-46724, UBUNTU-CVE-2023-46724

## What is CVE-2023-46724?

CVE-2023-46724 is a high-severity denial of service vulnerability in Squid-Cache Squid, published on 1 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.

Weakness: CWE-786 (Access of Memory Location Before Start of Buffer), CWE-823 (Use of Out-of-range Pointer Offset), CWE-129 (Improper Validation of Array Index), CWE-1285 (Improper Validation of Specified Index, Position, or Offset in Input), CWE-295 (Improper Certificate Validation), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2023-46724?

It affects 1 product.


Products: Squid-Cache Squid.

## How do I fix CVE-2023-46724?

Upgrade to a fixed version.

## Is CVE-2023-46724 being exploited?

There is no known exploitation of CVE-2023-46724 in the wild and no public exploit code.

## Other vulnerabilities in Squid-Cache Squid

- [CVE-2025-62168](https://insights.sbomify.com/CVE-2025-62168/): Squid vulnerable to information disclosure via authentication credential leakage in error handling (critical 10.0)
- [CVE-2025-54574](https://insights.sbomify.com/CVE-2025-54574/): Squid's URN Handling can lead to Buffer Overflow (critical 9.3)
- [CVE-2026-33526](https://insights.sbomify.com/CVE-2026-33526/): Squid vulnerable to Denial of Service in ICP Request handling (critical 9.2)
- [CVE-2026-32748](https://insights.sbomify.com/CVE-2026-32748/): Squid has Denial of Service in ICP Response handling (high 8.7)
- [CVE-2023-50269](https://insights.sbomify.com/CVE-2023-50269/): SQUID-2023:10 Denial of Service in HTTP Request parsing (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46724 and fix it if it is affected.

What it is: CVE-2023-46724 is a high-severity denial of service vulnerability in Squid-Cache Squid, published on 1 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46724 in the wild and no public exploit code.

Affected product: Squid-Cache Squid. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46724/ (Markdown: https://insights.sbomify.com/CVE-2023-46724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46724
- OSV: https://osv.dev/vulnerability/CVE-2023-46724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46724/
Summaries are generated and may contain mistakes; the official description above is the record.
