CVE-2023-46729 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint

Critical 9.3 Published Updated

Attackers can exploit the Next.js SDK tunnel endpoint to send requests to arbitrary URLs and read responses, affecting users with tunneling enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-46729?

CVE-2023-46729 is a critical server-side request forgery vulnerability in getsentry sentry-javascript, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.

Weakness: CWE-918

Which versions are affected by CVE-2023-46729?

2 open source packages ship an affected version, including @sentry/nextjs. It affects 1 product.

PackageAffectedFixed in
@sentry/nextjs npmFrom 7.26.07.77.0
@sentry/nextjs npmFrom 7.26.07.77.0

Products include Sentry Sentry Software Development Kit.

How do I fix CVE-2023-46729?

Upgrade @sentry/nextjs to 7.77.0 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2023-46729 being exploited?

There is no known exploitation of CVE-2023-46729 in the wild and no public exploit code.

Sources

Also known as GHSA-2rmr-xw8m-22q9.

Is CVE-2023-46729 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free