{"answers":{"affected":"2 open source packages ship an affected version, including @sentry/nextjs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46729 in the wild and no public exploit code.","fix":"Upgrade @sentry/nextjs to 7.77.0 or later.","what":"CVE-2023-46729 is a critical server-side request forgery vulnerability in getsentry sentry-javascript, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-46729 and fix it if it is affected.\n\nWhat it is: CVE-2023-46729 is a critical server-side request forgery vulnerability in getsentry sentry-javascript, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-46729 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @sentry/nextjs (npm): affected from 7.26.0; fixed in 7.77.0\n- @sentry/nextjs (npm): affected from 7.26.0; fixed in 7.77.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46729/ (Markdown: https://insights.sbomify.com/CVE-2023-46729/index.md)","id":"CVE-2023-46729","markdown":"https://insights.sbomify.com/CVE-2023-46729/index.md","name":"CVE-2023-46729","record":{"aliases":["GHSA-2rmr-xw8m-22q9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Sentry JavaScript SDK","requires_auth":"none","summary":"Attackers can exploit the Next.js SDK tunnel endpoint to send requests to arbitrary URLs and read responses, affecting users with tunneling enabled.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry_software_development_kit","vendor":"sentry"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint","id":"CVE-2023-46729","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Server-Side Request Forgery in groupoffice","id":"CVE-2023-46730"},"packages":[{"ecosystem":"npm","fixed":["7.77.0"],"introduced":["7.26.0"],"last_affected":[],"package":"@sentry/nextjs","purl":null,"source":"GHSA-2rmr-xw8m-22q9"},{"ecosystem":"npm","fixed":["7.77.0"],"introduced":["7.26.0"],"last_affected":[],"package":"@sentry/nextjs","purl":"pkg:npm/%40sentry/nextjs","source":"GHSA-2rmr-xw8m-22q9"}],"prev":{"headline":"SQUID-2021:8 Denial of Service in Gopher gateway","id":"CVE-2023-46728"},"products":["sentry-javascript"],"published":"2023-11-10","related":[{"cvss_score":7.6,"headline":"Sentry SDK leaks sensitive session information when `sendDefaultPII` is set to `True`","id":"CVE-2023-28117","kev_date_added":null,"published":"2023-03-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-03","vendors":["getsentry"]},"summary":"Attackers can exploit the Next.js SDK tunnel endpoint to send requests to arbitrary URLs and read responses, affecting users with tunneling enabled.","url":"https://insights.sbomify.com/CVE-2023-46729/"}