# CVE-2023-46729: Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint

> Attackers can exploit the Next.js SDK tunnel endpoint to send requests to arbitrary URLs and read responses, affecting users with tunneling enabled.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2023
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-2rmr-xw8m-22q9

## What is CVE-2023-46729?

CVE-2023-46729 is a critical server-side request forgery vulnerability in getsentry sentry-javascript, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-46729?

2 open source packages ship an affected version, including @sentry/nextjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sentry/nextjs` | npm | From 7.26.0 | 7.77.0 |
| `@sentry/nextjs` | npm | From 7.26.0 | 7.77.0 |

Products: Sentry Sentry Software Development Kit.

## How do I fix CVE-2023-46729?

Upgrade @sentry/nextjs to 7.77.0 or later.

## Is CVE-2023-46729 being exploited?

There is no known exploitation of CVE-2023-46729 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry-javascript

- [CVE-2023-28117](https://insights.sbomify.com/CVE-2023-28117/): Sentry SDK leaks sensitive session information when `sendDefaultPII` is set to `True` (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46729 and fix it if it is affected.

What it is: CVE-2023-46729 is a critical server-side request forgery vulnerability in getsentry sentry-javascript, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46729 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sentry/nextjs (npm): affected from 7.26.0; fixed in 7.77.0
- @sentry/nextjs (npm): affected from 7.26.0; fixed in 7.77.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46729/ (Markdown: https://insights.sbomify.com/CVE-2023-46729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46729
- OSV: https://osv.dev/vulnerability/CVE-2023-46729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46729/
Summaries are generated and may contain mistakes; the official description above is the record.
