CVE-2023-46733 Symfony possible session fixation vulnerability
Attackers can hijack user sessions by exploiting a failure to regenerate session IDs during specific login transitions in the Symfony framework.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-46733?
CVE-2023-46733 is a medium-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 10 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 5.4.21 and 6.2.7 and prior to versions 5.4.31 and 6.3.8, `SessionStrategyListener` does not migrate the session after every successful login. It does so only in case the logged in user changes by means of checking the user identifier. In some use cases, the user identifier doesn't change between the verification phase and the successful login, while the token itself changes from one type (partially-authenticated) to another (fully-authenticated). When this happens, the session id should be regenerated to prevent possible session fixations, which is not the case at the moment. As of versions 5.4.31 and 6.3.8, Symfony now checks the type of the token in addition to the user identifier before deciding whether the session id should be regenerated.
Weakness: CWE-384
Which versions are affected by CVE-2023-46733?
9 open source packages ship an affected version, including symfony/security-http, symfony and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security-http Packagist | From 5.4.21 | 5.4.31 |
symfony/security-http Packagist | From 5.4.21 | 5.4.31 |
symfony/security-http Packagist | From 6.2.7 | 6.3.8 |
symfony/security-http Packagist | From 6.2.7 | 6.3.8 |
symfony Bitnami | From 5.4.21 | 5.4.31, 6.3.8 |
symfony/symfony Packagist | From 5.4.21 | 5.4.31 |
3 more packages
symfony/symfony Packagist | From 5.4.21 | 5.4.31 |
symfony/symfony Packagist | From 6.2.7 | 6.3.8 |
symfony/symfony Packagist | From 6.2.7 | 6.3.8 |
Products include Sensiolabs Symfony.
How do I fix CVE-2023-46733?
Upgrade symfony/security-http to a fixed version for your release line: 5.4.31 or 6.3.8.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-46733 being exploited?
There is no known exploitation of CVE-2023-46733 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as BIT-symfony-2023-46733, DEBIAN-CVE-2023-46733, GHSA-m2wj-r6g3-fxfx.