# CVE-2023-46733: Symfony possible session fixation vulnerability

> Attackers can hijack user sessions by exploiting a failure to regenerate session IDs during specific login transitions in the Symfony framework.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2023
- **Updated:** 3 Sep 2024
- **Also known as:** BIT-symfony-2023-46733, DEBIAN-CVE-2023-46733, GHSA-m2wj-r6g3-fxfx

## What is CVE-2023-46733?

CVE-2023-46733 is a medium-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 10 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 5.4.21 and 6.2.7 and prior to versions 5.4.31 and 6.3.8, `SessionStrategyListener` does not migrate the session after every successful login. It does so only in case the logged in user changes by means of checking the user identifier. In some use cases, the user identifier doesn't change between the verification phase and the successful login, while the token itself changes from one type (partially-authenticated) to another (fully-authenticated). When this happens, the session id should be regenerated to prevent possible session fixations, which is not the case at the moment. As of versions 5.4.31 and 6.3.8, Symfony now checks the type of the token in addition to the user identifier before deciding whether the session id should be regenerated.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2023-46733?

9 open source packages ship an affected version, including symfony/security-http, symfony and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security-http` | Packagist | From 5.4.21 | 5.4.31 |
| `symfony/security-http` | Packagist | From 5.4.21 | 5.4.31 |
| `symfony/security-http` | Packagist | From 6.2.7 | 6.3.8 |
| `symfony/security-http` | Packagist | From 6.2.7 | 6.3.8 |
| `symfony` | Bitnami | From 5.4.21 | 5.4.31, 6.3.8 |
| `symfony/symfony` | Packagist | From 5.4.21 | 5.4.31 |
| `symfony/symfony` | Packagist | From 5.4.21 | 5.4.31 |
| `symfony/symfony` | Packagist | From 6.2.7 | 6.3.8 |
| `symfony/symfony` | Packagist | From 6.2.7 | 6.3.8 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2023-46733?

Upgrade symfony/security-http to a fixed version for your release line: 5.4.31 or 6.3.8.

## Is CVE-2023-46733 being exploited?

There is no known exploitation of CVE-2023-46733 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46733 and fix it if it is affected.

What it is: CVE-2023-46733 is a medium-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 10 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46733 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security-http (Packagist): affected from 5.4.21; fixed in 5.4.31
- symfony/security-http (Packagist): affected from 5.4.21; fixed in 5.4.31
- symfony/security-http (Packagist): affected from 6.2.7; fixed in 6.3.8
- symfony/security-http (Packagist): affected from 6.2.7; fixed in 6.3.8
- symfony (Bitnami): affected from 5.4.21; fixed in 5.4.31, 6.3.8
- symfony/symfony (Packagist): affected from 5.4.21; fixed in 5.4.31
- symfony/symfony (Packagist): affected from 5.4.21; fixed in 5.4.31
- symfony/symfony (Packagist): affected from 6.2.7; fixed in 6.3.8
- symfony/symfony (Packagist): affected from 6.2.7; fixed in 6.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46733/ (Markdown: https://insights.sbomify.com/CVE-2023-46733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46733
- OSV: https://osv.dev/vulnerability/CVE-2023-46733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46733/
Summaries are generated and may contain mistakes; the official description above is the record.
