# CVE-2023-46734: Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters

> Attackers can inject malicious scripts via Twig filters in Symfony, potentially leading to code execution or session hijacking.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-symfony-2023-46734, DEBIAN-CVE-2023-46734, DLA-3664-1, GHSA-q847-2q57-wmr3, UBUNTU-CVE-2023-46734

## What is CVE-2023-46734?

CVE-2023-46734 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-46734?

13 open source packages ship an affected version, including symfony/symfony, symfony and symfony/twig-bridge. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/symfony` | Packagist | From 2.0.0 | 4.4.51 |
| `symfony/symfony` | Packagist | From 2.0.0 | 4.4.51 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.4.31 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.4.31 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.3.8 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.3.8 |
| `symfony` | Bitnami | From 2.0.0 | 4.4.51, 5.4.31, 6.3.8 |
| `symfony/twig-bridge` | Packagist | From 2.0.0 | 4.4.51 |
| `symfony/twig-bridge` | Packagist | From 2.0.0 | 4.4.51 |
| `symfony/twig-bridge` | Packagist | From 5.0.0 | 5.4.31 |
| `symfony/twig-bridge` | Packagist | From 5.0.0 | 5.4.31 |
| `symfony/twig-bridge` | Packagist | From 6.0.0 | 6.3.8 |
| `symfony/twig-bridge` | Packagist | From 6.0.0 | 6.3.8 |

Products: Debian Debian Linux, Sensiolabs Symfony, Symfony Twig-Bridge.

## How do I fix CVE-2023-46734?

Upgrade symfony/symfony to a fixed version for your release line: 4.4.51, 5.4.31 or 6.3.8.

## Is CVE-2023-46734 being exploited?

There is no known exploitation of CVE-2023-46734 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46734 and fix it if it is affected.

What it is: CVE-2023-46734 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46734 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 4.4.51
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 4.4.51
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.4.31
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.4.31
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.3.8
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.3.8
- symfony (Bitnami): affected from 2.0.0; fixed in 4.4.51, 5.4.31, 6.3.8
- symfony/twig-bridge (Packagist): affected from 2.0.0; fixed in 4.4.51
- symfony/twig-bridge (Packagist): affected from 2.0.0; fixed in 4.4.51
- symfony/twig-bridge (Packagist): affected from 5.0.0; fixed in 5.4.31
- symfony/twig-bridge (Packagist): affected from 5.0.0; fixed in 5.4.31
- symfony/twig-bridge (Packagist): affected from 6.0.0; fixed in 6.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46734/ (Markdown: https://insights.sbomify.com/CVE-2023-46734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46734
- OSV: https://osv.dev/vulnerability/CVE-2023-46734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46734/
Summaries are generated and may contain mistakes; the official description above is the record.
