# CVE-2023-46745: Rate limiting Bypass on login page in libreNMS

> Attackers can bypass login rate limits to brute-force user accounts in LibreNMS, potentially gaining unauthorized access.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2023
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-rq42-58qf-v3qx

## What is CVE-2023-46745?

CVE-2023-46745 is a medium-severity vulnerability in Librenms Librenms, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems. In affected versions the login method has no rate limit. An attacker may be able to leverage this vulnerability to gain access to user accounts. This issue has been addressed in version 23.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2023-46745?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 23.11.0 |
| `librenms/librenms` | Packagist | All versions | 23.11.0 |

Products: Librenms Librenms.

## How do I fix CVE-2023-46745?

Upgrade librenms/librenms to 23.11.0 or later.

## Is CVE-2023-46745 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46745 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46745 and fix it if it is affected.

What it is: CVE-2023-46745 is a medium-severity vulnerability in Librenms Librenms, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46745 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 23.11.0
- librenms/librenms (Packagist): affected all versions; fixed in 23.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46745/ (Markdown: https://insights.sbomify.com/CVE-2023-46745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46745
- OSV: https://osv.dev/vulnerability/CVE-2023-46745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46745/
Summaries are generated and may contain mistakes; the official description above is the record.
