# CVE-2023-46801: Apache Linkis DataSource: DataSource Remote code execution vulnerability

> Authenticated attackers can achieve remote code execution via deserialization in Apache Linkis DataSource when using vulnerable Java versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2024
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-jjvc-v8gw-5255

## What is CVE-2023-46801?

CVE-2023-46801 is a high-severity unsafe deserialization vulnerability in Apache Linkis DataSource, published on 15 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. 

This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.  We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-46801?

2 open source packages ship an affected version, including org.apache.linkis:linkis-datasource. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis-datasource` | Maven | From 1.4.0 | 1.6.0 |
| `org.apache.linkis:linkis-datasource` | Maven | From 1.4.0 | 1.6.0 |

Products: Apache Linkis.

## How do I fix CVE-2023-46801?

Upgrade org.apache.linkis:linkis-datasource to 1.6.0 or later.

## Is CVE-2023-46801 being exploited?

There is no known exploitation of CVE-2023-46801 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis DataSource

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46801 and fix it if it is affected.

What it is: CVE-2023-46801 is a high-severity unsafe deserialization vulnerability in Apache Linkis DataSource, published on 15 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46801 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis-datasource (Maven): affected from 1.4.0; fixed in 1.6.0
- org.apache.linkis:linkis-datasource (Maven): affected from 1.4.0; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46801/ (Markdown: https://insights.sbomify.com/CVE-2023-46801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46801
- OSV: https://osv.dev/vulnerability/CVE-2023-46801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46801/
Summaries are generated and may contain mistakes; the official description above is the record.
