# CVE-2023-46852: Memory corruption in n/a

> A buffer overflow in Memcached proxy mode allows attackers to execute arbitrary code or cause denial of service via crafted multiget requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2023
- **Updated:** 9 Sep 2024
- **Also known as:** AZL-31716, AZL-34976, BIT-memcached-2023-46852, DEBIAN-CVE-2023-46852, GHSA-47qj-rqv2-98f2, UBUNTU-CVE-2023-46852

## What is CVE-2023-46852?

CVE-2023-46852 is a high-severity memory corruption vulnerability in n/a, published on 27 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2023-46852?

1 open source package ship an affected version, including memcached. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `memcached` | Bitnami | All versions | 1.6.22 |

Products: Memcached Memcached.

## How do I fix CVE-2023-46852?

Upgrade memcached to 1.6.22 or later.

## Is CVE-2023-46852 being exploited?

There is no known exploitation of CVE-2023-46852 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-46853](https://insights.sbomify.com/CVE-2023-46853/): Memory corruption in n/a (critical 9.8)
- [CVE-2016-8704](https://insights.sbomify.com/CVE-2016-8704/): Integer overflow in Memcached (critical 9.8)
- [CVE-2016-8705](https://insights.sbomify.com/CVE-2016-8705/): Integer overflow in Memcached (critical 9.8)
- [CVE-2026-47783](https://insights.sbomify.com/CVE-2026-47783/): Information disclosure in memcached (high 8.1)
- [CVE-2026-47784](https://insights.sbomify.com/CVE-2026-47784/): Information disclosure in memcached (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46852 and fix it if it is affected.

What it is: CVE-2023-46852 is a high-severity memory corruption vulnerability in n/a, published on 27 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46852 in the wild and no public exploit code.

Affected packages and fixed versions:
- memcached (Bitnami): affected all versions; fixed in 1.6.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46852/ (Markdown: https://insights.sbomify.com/CVE-2023-46852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46852
- OSV: https://osv.dev/vulnerability/CVE-2023-46852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46852/
Summaries are generated and may contain mistakes; the official description above is the record.
