# CVE-2023-46853: Memory corruption in n/a

> An off-by-one error in Memcached proxy mode allows attackers to cause memory corruption, potentially leading to crashes or code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2023
- **Updated:** 9 Sep 2024
- **Also known as:** AZL-31732, AZL-34977, BIT-memcached-2023-46853, DEBIAN-CVE-2023-46853, GHSA-jr2m-hrp3-3wj4, ROOT-OS-ALPINE-317-CVE-2023-46853, ROOT-OS-ALPINE-318-CVE-2023-46853, UBUNTU-CVE-2023-46853

## What is CVE-2023-46853?

CVE-2023-46853 is a critical memory corruption vulnerability in n/a, published on 27 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Memcached before 1.6.22, an off-by-one error exists when processing proxy requests in proxy mode, if \n is used instead of \r\n.

Weakness: CWE-193 (Off-by-one Error)

## Which versions are affected by CVE-2023-46853?

1 open source package ship an affected version, including memcached. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `memcached` | Bitnami | All versions | 1.6.22 |

Products: Memcached Memcached.

## How do I fix CVE-2023-46853?

Upgrade memcached to 1.6.22 or later.

## Is CVE-2023-46853 being exploited?

There is no known exploitation of CVE-2023-46853 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-8704](https://insights.sbomify.com/CVE-2016-8704/): Integer overflow in Memcached (critical 9.8)
- [CVE-2016-8705](https://insights.sbomify.com/CVE-2016-8705/): Integer overflow in Memcached (critical 9.8)
- [CVE-2026-47783](https://insights.sbomify.com/CVE-2026-47783/): Information disclosure in memcached (high 8.1)
- [CVE-2026-47784](https://insights.sbomify.com/CVE-2026-47784/): Information disclosure in memcached (high 8.1)
- [CVE-2016-8706](https://insights.sbomify.com/CVE-2016-8706/): Integer overflow in Memcached (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46853 and fix it if it is affected.

What it is: CVE-2023-46853 is a critical memory corruption vulnerability in n/a, published on 27 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46853 in the wild and no public exploit code.

Affected packages and fixed versions:
- memcached (Bitnami): affected all versions; fixed in 1.6.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46853/ (Markdown: https://insights.sbomify.com/CVE-2023-46853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46853
- OSV: https://osv.dev/vulnerability/CVE-2023-46853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46853/
Summaries are generated and may contain mistakes; the official description above is the record.
