{"answers":{"affected":"3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4697 exists.","fix":"Upgrade github.com/usememos/memos to 0.13.2 or later.","what":"CVE-2023-4697 is a high-severity vulnerability in Usememos Memos, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-4697 and fix it if it is affected.\n\nWhat it is: CVE-2023-4697 is a high-severity vulnerability in Usememos Memos, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4697 exists.\n\nAffected packages and fixed versions:\n- github.com/usememos/memos (Go): affected all versions; fixed in 0.13.2\n- github.com/usememos/memos (Go): affected all versions; fixed in 0.13.2\n- github.com/usememos/memos (Go): affected all versions; fixed in 0.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4697/ (Markdown: https://insights.sbomify.com/CVE-2023-4697/index.md)","id":"CVE-2023-4697","markdown":"https://insights.sbomify.com/CVE-2023-4697/index.md","name":"CVE-2023-4697","record":{"aliases":["GHSA-5j6p-59cj-j6cp","GO-2023-2036"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Memos note-taking app","requires_auth":"low_privilege","summary":"Attackers can escalate privileges in the Memos web application due to improper privilege management, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"memos","vendor":"usememos"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Improper Privilege Management in GitHub repository usememos/memos prior to 0.13.2.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Privilege Management in usememos/memos","id":"CVE-2023-4697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"usememos:memos","products":["usememos:memos"],"type":"privilege_escalation","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Improper Input Validation in usememos/memos","id":"CVE-2023-4698"},"packages":[{"ecosystem":"Go","fixed":["0.13.2"],"introduced":["0"],"last_affected":[],"package":"github.com/usememos/memos","purl":null,"source":"GHSA-5j6p-59cj-j6cp"},{"ecosystem":"Go","fixed":["0.13.2"],"introduced":["0"],"last_affected":[],"package":"github.com/usememos/memos","purl":"pkg:golang/github.com/usememos/memos","source":"GHSA-5j6p-59cj-j6cp"},{"ecosystem":"Go","fixed":["0.13.2"],"introduced":["0"],"last_affected":[],"package":"github.com/usememos/memos","purl":"pkg:golang/github.com/usememos/memos","source":"GO-2023-2036"}],"prev":{"headline":"Improper Access Control in usememos/memos","id":"CVE-2023-4696"},"products":["usememos/memos"],"published":"2023-09-01","related":[{"cvss_score":9.8,"headline":"Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs","id":"CVE-2025-50738","kev_date_added":null,"published":"2025-07-29"},{"cvss_score":9.8,"headline":"Memos Server-Side Request Forgery (SSRF)","id":"CVE-2025-22952","kev_date_added":null,"published":"2025-02-27"},{"cvss_score":9.8,"headline":"Stored XSS in usememos/memos","id":"CVE-2023-0109","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":9.8,"headline":"Improper Access Control in usememos/memos","id":"CVE-2023-4696","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in usememos/memos","id":"CVE-2022-4866","kev_date_added":null,"published":"2022-12-31"},{"cvss_score":9.8,"headline":"Improper Handling of Values in usememos/memos","id":"CVE-2022-4851","kev_date_added":null,"published":"2022-12-29"},{"cvss_score":9.8,"headline":"Improper Restriction of Excessive Authentication Attempts in usememos/memos","id":"CVE-2022-4797","kev_date_added":null,"published":"2022-12-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-01","vendors":["usememos"]},"summary":"Attackers can escalate privileges in the Memos web application due to improper privilege management, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-4697/"}