CVE-2023-4700 Missing Authorization in GitLab
Attackers can bypass approval requirements to run jobs in protected environments within GitLab Enterprise Edition.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-4700?
CVE-2023-4700 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 6 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An authorization issue affecting GitLab EE affecting all versions from 14.7 prior to 16.3.6, 16.4 prior to 16.4.2, and 16.5 prior to 16.5.1, allowed a user to run jobs in protected environments, bypassing any required approvals.
Weakness: CWE-862
Which versions are affected by CVE-2023-4700?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.7.0 | 16.3.6, 16.4.2, 16.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-4700?
Upgrade gitlab to a fixed version for your release line: 16.3.6, 16.4.2 or 16.5.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-4700 being exploited?
There is no known exploitation of CVE-2023-4700 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-4700, GHSA-j8mj-5fpw-2pc8.