# CVE-2023-47090: NATS.io: Adding accounts for just the system account adds auth bypass

> Attackers can bypass authentication in NATS server if an implicit $G user is configured, allowing unauthorized access to the system.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2023
- **Updated:** 9 Sep 2024
- **Also known as:** AZL-31779, AZL-35301, DEBIAN-CVE-2023-47090, GHSA-fr2g-9hjm-wr23, GO-2023-2133, JLSEC-2026-1119

## What is CVE-2023-47090?

CVE-2023-47090 is a medium-severity authentication bypass vulnerability in n/a, published on 30 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NATS nats-server before 2.9.23 and 2.10.x before 2.10.2 has an authentication bypass. An implicit $G user in an authorization block can sometimes be used for unauthenticated access, even when the intention of the configuration was for each user to have an account. The earliest affected version is 2.2.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-47090?

5 open source packages ship an affected version, including github.com/nats-io/nats-server/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | From 2.10.0 | 2.10.2 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.10.0 | 2.10.2 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.2.0 | 2.9.23, 2.10.2 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.2.0 | 2.9.23 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.2.0 | 2.9.23 |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2023-47090?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.10.2 or 2.9.23.

## Is CVE-2023-47090 being exploited?

There is no known exploitation of CVE-2023-47090 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47090 and fix it if it is affected.

What it is: CVE-2023-47090 is a medium-severity authentication bypass vulnerability in n/a, published on 30 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47090 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected from 2.10.0; fixed in 2.10.2
- github.com/nats-io/nats-server/v2 (Go): affected from 2.10.0; fixed in 2.10.2
- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.9.23, 2.10.2
- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.9.23
- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.9.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47090/ (Markdown: https://insights.sbomify.com/CVE-2023-47090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47090
- OSV: https://osv.dev/vulnerability/CVE-2023-47090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47090/
Summaries are generated and may contain mistakes; the official description above is the record.
