# CVE-2023-47108: DoS vulnerability in otelgrpc (uncontrolled resource consumption) due to unbound cardinality metrics

> An attacker can cause memory exhaustion and denial of service in applications using the OpenTelemetry Go gRPC interceptor by flooding requests with unique peer addresses.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2023
- **Updated:** 28 Oct 2025
- **Also known as:** AZL-31896, AZL-34620, AZL-34891, AZL-34995, AZL-35434, AZL-35440, AZL-42745, CLEANSTART-2025-LI04591, CLEANSTART-2025-VC45240, CLEANSTART-2026-NU37715, GHSA-8pgv-569h-w5rw, GO-2023-2331, MINI-848c-f6vw-qmg8, MINI-8jw6-x77f-93hf, RHSA-2024:0288, RHSA-2024:0489, SUSE-SU-2025:20385-1, UBUNTU-CVE-2023-47108, openSUSE-SU-2024:13615-1, openSUSE-SU-2024:14032-1

## What is CVE-2023-47108?

CVE-2023-47108 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-go-contrib, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenTelemetry-Go Contrib is a collection of third-party packages for OpenTelemetry-Go. Starting in version 0.37.0 and prior to version 0.46.0, the grpc Unary Server Interceptor out of the box adds labels `net.peer.sock.addr` and `net.peer.sock.port` that have unbound cardinality. It leads to the server's potential memory exhaustion when many malicious requests are sent. An attacker can easily flood the peer address and port for requests. Version 0.46.0 contains a fix for this issue. As a workaround to stop being affected, a view removing the attributes can be used. The other possibility is to disable grpc metrics instrumentation by passing `otelgrpc.WithMeterProvider` option with `noop.NewMeterProvider`.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-47108?

3 open source packages ship an affected version, including go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc` | Go | From 0.37.0 | 0.46.0 |
| `go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc` | Go | From 0.37.0 | 0.46.0 |
| `go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc` | Go | From 0.37.0 | 0.46.0 |
| `cri-o` | Red Hat:openshift:4.12::el8 | All versions | 0:1.25.5-6.rhaos4.12.gitfcf6ef3.el8 |
| `cri-o-debuginfo` | Red Hat:openshift:4.12::el8 | All versions | 0:1.25.5-6.rhaos4.12.gitfcf6ef3.el8 |
| `cri-o-debugsource` | Red Hat:openshift:4.12::el8 | All versions | 0:1.25.5-6.rhaos4.12.gitfcf6ef3.el8 |
| `cri-o` | Red Hat:openshift:4.13::el8 | All versions | 0:1.26.4-9.1.rhaos4.13.gite26e057.el8 |
| `cri-o-debuginfo` | Red Hat:openshift:4.13::el8 | All versions | 0:1.26.4-9.1.rhaos4.13.gite26e057.el8 |
| `cri-o-debugsource` | Red Hat:openshift:4.13::el8 | All versions | 0:1.26.4-9.1.rhaos4.13.gite26e057.el8 |
| `cri-o` | Red Hat:openshift:4.13::el9 | All versions | 0:1.26.4-9.1.rhaos4.13.gite26e057.el9 |
| `cri-o-debuginfo` | Red Hat:openshift:4.13::el9 | All versions | 0:1.26.4-9.1.rhaos4.13.gite26e057.el9 |
| `cri-o-debugsource` | Red Hat:openshift:4.13::el9 | All versions | 0:1.26.4-9.1.rhaos4.13.gite26e057.el9 |
| `docker-compose` | SUSE:Linux Micro 6.0 | All versions | 2.33.1-1.1 |
| `etcd` | openSUSE:Tumbleweed | All versions | 3.5.11-1.1 |
| `okteto` | openSUSE:Tumbleweed | All versions | 2.28.0-1.1 |

Products: Opentelemetry Opentelemetry.

## How do I fix CVE-2023-47108?

Upgrade go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc to 0.46.0 or later.

## Is CVE-2023-47108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47108 exists.

Public exploit code:

- https://github.com/bahe-msft/govuln-CVE-2023-47108 (github_poc): https://github.com/bahe-msft/govuln-CVE-2023-47108

## Other vulnerabilities in open-telemetry opentelemetry-go-contrib

- [CVE-2026-29181](https://insights.sbomify.com/CVE-2026-29181/): OpenTelemetry-Go multi-value `baggage` header extraction causes excessive allocations (remote dos amplification) (high 7.5)
- [CVE-2023-45142](https://insights.sbomify.com/CVE-2023-45142/): OpenTelemetry-Go Contrib has DoS vulnerability in otelhttp due to unbound cardinality metrics (high 7.5)
- [CVE-2023-43810](https://insights.sbomify.com/CVE-2023-43810/): opentelemetry-instrumentation Denial of Service vulnerability due to unbound cardinality metrics (high 7.5)
- [CVE-2026-39883](https://insights.sbomify.com/CVE-2026-39883/): opentelemetry-go: BSD kenv command not using absolute path enables PATH hijacking (high 7.3)
- [CVE-2026-24051](https://insights.sbomify.com/CVE-2026-24051/): OpenTelemetry-Go Affected by Arbitrary Code Execution via PATH Hijacking (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47108 and fix it if it is affected.

What it is: CVE-2023-47108 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-go-contrib, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47108 exists.

Affected packages and fixed versions:
- go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc (Go): affected from 0.37.0; fixed in 0.46.0
- go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc (Go): affected from 0.37.0; fixed in 0.46.0
- go.opentelemetry.io/contrib/instrumentation/google.golang.org/grpc/otelgrpc (Go): affected from 0.37.0; fixed in 0.46.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47108/ (Markdown: https://insights.sbomify.com/CVE-2023-47108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47108
- OSV: https://osv.dev/vulnerability/CVE-2023-47108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47108/
Summaries are generated and may contain mistakes; the official description above is the record.
