# CVE-2023-47110: Any value can be changed in the configuration table by an employee having access to block reassurance module

> An authenticated employee can arbitrarily modify configuration values via an insecure AJAX endpoint in the PrestaShop blockreassurance module.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2023
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-xfm3-hjcc-gv78

## What is CVE-2023-47110?

CVE-2023-47110 is a critical missing authorization vulnerability in PrestaShop blockreassurance, published on 9 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

blockreassurance adds an information block aimed at offering helpful information to reassure customers that their store is trustworthy. An ajax function in module blockreassurance allows modifying any value in the configuration table. This vulnerability has been patched in version 5.1.4.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-47110?

2 open source packages ship an affected version, including prestashop/blockreassurance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/blockreassurance` | Packagist | All versions | 5.1.4 |
| `prestashop/blockreassurance` | Packagist | All versions | 5.1.4 |

Products: Prestashop Customer Reassurance Block.

## How do I fix CVE-2023-47110?

Upgrade prestashop/blockreassurance to 5.1.4 or later.

## Is CVE-2023-47110 being exploited?

There is no known exploitation of CVE-2023-47110 in the wild and no public exploit code.

## Other vulnerabilities in PrestaShop blockreassurance

- [CVE-2023-47109](https://insights.sbomify.com/CVE-2023-47109/): PrestaShop blockreassurance BO User can remove any file from server when adding a and deleting a block (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47110 and fix it if it is affected.

What it is: CVE-2023-47110 is a critical missing authorization vulnerability in PrestaShop blockreassurance, published on 9 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47110 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/blockreassurance (Packagist): affected all versions; fixed in 5.1.4
- prestashop/blockreassurance (Packagist): affected all versions; fixed in 5.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47110/ (Markdown: https://insights.sbomify.com/CVE-2023-47110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47110
- OSV: https://osv.dev/vulnerability/CVE-2023-47110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47110/
Summaries are generated and may contain mistakes; the official description above is the record.
