CVE-2023-47114 Ethyca Fides HTML Injection Vulnerability in HTML-Formatted DSR Packages

Medium 4.3 Published Updated

Attackers can inject malicious HTML or JavaScript into data subject access request packages, potentially leading to code execution in the victim's browser.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-47114?

CVE-2023-47114 is a medium-severity cross-site scripting vulnerability in ethyca fides, published on 8 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in your runtime environment, and the enforcement of privacy regulations in your code. The Fides web application allows data subject users to request access to their personal data. If the request is approved by the data controller user operating the Fides web application, the data subject's personal data can then retrieved from connected systems and data stores before being bundled together as a data subject access request package for the data subject to download. Supported data formats for the package include json and csv, but the most commonly used format is a series of HTML files compressed in a ZIP file. Once downloaded and unzipped, the data subject user can browse the HTML files on their local machine. It was identified that there was no validation of input coming from e.g. the connected systems and data stores which is later reflected in the downloaded data. This can result in an HTML injection that can be abused e.g. for phishing attacks or malicious JavaScript code execution, but only in the context of the data subject's browser accessing a HTML page using the `file://` protocol. Exploitation is limited to rogue Admin UI users, malicious connected system / data store users, and the data subject user if tricked via social engineering into submitting malicious data themselves. This vulnerability has been patched in version 2.23.3.

Weakness: CWE-79

Which versions are affected by CVE-2023-47114?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.

PackageAffectedFixed in
ethyca-fides PyPIFrom 2.15.12.23.3
ethyca-fides PyPIFrom 2.15.12.23.3
ethyca-fides PyPIFrom 2.15.12.23.3

Products include Ethyca Fides.

How do I fix CVE-2023-47114?

Upgrade ethyca-fides to 2.23.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-47114 being exploited?

There is no known exploitation of CVE-2023-47114 in the wild and no public exploit code.

Sources

Also known as GHSA-3vpf-mcj7-5h38, PYSEC-2026-1333.

Is CVE-2023-47114 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free