# CVE-2023-47114: Ethyca Fides HTML Injection Vulnerability in HTML-Formatted DSR Packages

> Attackers can inject malicious HTML or JavaScript into data subject access request packages, potentially leading to code execution in the victim's browser.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Nov 2023
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-3vpf-mcj7-5h38, PYSEC-2026-1333

## What is CVE-2023-47114?

CVE-2023-47114 is a medium-severity cross-site scripting vulnerability in ethyca fides, published on 8 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in your runtime environment, and the enforcement of privacy regulations in your code. The Fides web application allows data subject users to request access to their personal data. If the request is approved by the data controller user operating the Fides web application, the data subject's personal data can then retrieved from connected systems and data stores before being bundled together as a data subject access request package for the data subject to download. Supported data formats for the package include json and csv, but the most commonly used format is a series of HTML files compressed in a ZIP file. Once downloaded and unzipped, the data subject user can browse the HTML files on their local machine. It was identified that there was no validation of input coming from e.g. the connected systems and data stores which is later reflected in the downloaded data. This can result in an HTML injection that can be abused e.g. for phishing attacks or malicious JavaScript code execution, but only in the context of the data subject's browser accessing a HTML page using the `file://` protocol. Exploitation is limited to rogue Admin UI users, malicious connected system / data store users, and the data subject user if tricked via social engineering into submitting malicious data themselves. This vulnerability has been patched in version 2.23.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-47114?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | From 2.15.1 | 2.23.3 |
| `ethyca-fides` | PyPI | From 2.15.1 | 2.23.3 |
| `ethyca-fides` | PyPI | From 2.15.1 | 2.23.3 |

Products: Ethyca Fides.

## How do I fix CVE-2023-47114?

Upgrade ethyca-fides to 2.23.3 or later.

## Is CVE-2023-47114 being exploited?

There is no known exploitation of CVE-2023-47114 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47114 and fix it if it is affected.

What it is: CVE-2023-47114 is a medium-severity cross-site scripting vulnerability in ethyca fides, published on 8 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-47114 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected from 2.15.1; fixed in 2.23.3
- ethyca-fides (PyPI): affected from 2.15.1; fixed in 2.23.3
- ethyca-fides (PyPI): affected from 2.15.1; fixed in 2.23.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47114/ (Markdown: https://insights.sbomify.com/CVE-2023-47114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47114
- OSV: https://osv.dev/vulnerability/CVE-2023-47114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47114/
Summaries are generated and may contain mistakes; the official description above is the record.
