# CVE-2023-47120: Discourse DoS through Onebox favicon URL

> Attackers can deplete Redis memory and cause denial of service by crafting posts with abnormally long favicon URLs in Discourse.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2023
- **Updated:** 3 Sep 2024
- **Also known as:** BIT-discourse-2023-47120, GHSA-77cw-xhj8-hfp3

## What is CVE-2023-47120?

CVE-2023-47120 is a high-severity denial of service vulnerability in Discourse Discourse, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. In versions 3.1.0 through 3.1.2 of the `stable` branch and versions 3.1.0,beta6 through 3.2.0.beta2 of the `beta` and `tests-passed` branches, Redis memory can be depleted by crafting a site with an abnormally long favicon URL and drafting multiple posts which Onebox it. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-47120?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | From 3.1.0 | 3.1.3 |

Products: Discourse Discourse.

## How do I fix CVE-2023-47120?

Upgrade discourse to 3.1.3 or later.

## Is CVE-2023-47120 being exploited?

There is no known exploitation of CVE-2023-47120 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47120 and fix it if it is affected.

What it is: CVE-2023-47120 is a high-severity denial of service vulnerability in Discourse Discourse, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47120 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected from 3.1.0; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47120/ (Markdown: https://insights.sbomify.com/CVE-2023-47120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47120
- OSV: https://osv.dev/vulnerability/CVE-2023-47120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47120/
Summaries are generated and may contain mistakes; the official description above is the record.
