CVE-2023-47121 Discourse SSRF vulnerability in Embedding

Low 3.4 Published Updated

Attackers can exploit the embedding feature to perform server-side request forgery, potentially accessing internal resources or bypassing security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-47121?

CVE-2023-47121 is a low-severity server-side request forgery vulnerability in Discourse Discourse, published on 10 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.

Weakness: CWE-918

Which versions are affected by CVE-2023-47121?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.2.0

Products include Discourse Discourse.

How do I fix CVE-2023-47121?

Upgrade discourse to 3.2.0 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2023-47121 being exploited?

There is no known exploitation of CVE-2023-47121 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-47121, GHSA-hp24-94qf-8cgc.

Is CVE-2023-47121 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free